Check out the LimeSurvey source code on GitHub!

Unbekanntes Limit an Fragen vorhanden?

More
4 years 3 months ago - 4 years 3 months ago #87052 by orvil
Hallo!

Entweder bin ich an ein (mir) nicht bekanntes Limit von möglichen Fragen (so viel sind es aber nicht) gestoßen oder ich übersehe irgendetwas.

Habe testweise für eine Datenerfassung einen FB erstellt und ab einer gewissen Stelle klappt es nicht mehr. Der Unterschied ist eine Frage mehr oder weniger. Es sind jedes mal aber Matrixfragen(Text).

Um sicher zu sein hab ich schon alle Bedingungen, Plichtangaben usw. weggelassen.

Hat jemand eine Idee woran das liegen kann? Oder schon ähnliche Erfahrung gemacht?

Hier die Hintergundinfo:
LS Version 2.00+ Build 121017, MySQL 5.1.63, PHP Version 5.2.17
Mit der letzten 1.92+ Version hat es auch nicht funktioniert, wohl aber mit einer (mir leider nicht mehr bekannten Vorversion von 1.92+)

Hab zwei *.lls Files angehängt, die sich in genau einer Frage unterscheiden und den Unterschied zwischen funktioniert und funktioniert nicht ausmacht.

Liegrü
Orvil

Nachtrag (sorry): Was nicht funktioniert = der FB lässt sich zwar aufrufen und editieren, wenn man aber speichert, werden keine Daten in die Datenbank geschrieben. Man merkt es auch daran, dass die vorgesehene End-Url nicht aufgerufen wird (in den Beispielen die LimeSurvey URL) sondern die Umfragen-Übersicht erscheint.

Best regards/Beste Grüße,
O. Villani
Attachments:
Last Edit: 4 years 3 months ago by orvil. Reason: Nachtrag

Please Log in to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #87079 by c_schmitz
Das hat mit der Version höchstwahrscheinlich nichts zu tun, sondern mit den Servereinstellungen.
Wirf einen Blick auf die FAQ und schau ob dies dein Problem löst.

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 4 years 3 months ago by c_schmitz.
The following user(s) said Thank You: orvil

Please Log in to join the conversation.

More
4 years 3 months ago #87122 by orvil
Danke für den Tipp!

Es war die php.ini, die Variable max_input_vars war nach einem Update auf php 3.5.10 zu niedrig eingestellt.

Also hab ich im LimeSurvey Ordner eine eine php.ini nur mit dem Eintrag
max_input_vars = 1024
angelegt und schon klappt es!

LG
Orvil

Best regards/Beste Grüße,
O. Villani

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form