Check out the LimeSurvey source code on GitHub!

Fragen bleiben ausgeblendet in IE7

More
5 years 5 months ago #65047 by sari2108
Hallo Leute,

ich habe ein Problem mit einer laufenden Umfrage. Ein Teilnehmer (arbeitet mit IE7) hat sich bei mir gemeldet und meinte, dass er auf einer bestimmten Seite die Meldung bekommt, Pflichtfragen nicht beantwortet zu haben, obwohl alle Fragen beantwortet waren. Ein Screenshot hat mir dann gezeigt, dass einige Fragen in seiner Ansicht gar nicht zu sehen waren. Die ausgeblendeten Fragen sind an Bedingung geknüpft, die - soweit ich das richtig verstanden habe - erfüllt sind.
Am Anfang der Umfrage wird nämlich das Geschlecht des Teilnehmers abgefragt, davon hängen dann die weiteren Fragen ab.
Die Frage zum Geschlecht ist ebenfalls verpflichtend. Diese Frage wiederum hat der Teilnehmer letzte Woche nicht, bei wiederholtem Durchführen heute aber schon angezeigt bekommen.
Ich konnte das Problem auch nicht reproduzieren, mit Firefox und Chrome läuft alles ohne Probleme.

Alles ein bisschen verwirrend, ich hoffe ich habe es trotzdem einigermaßen klar ausgedrückt.

Zur Info:
LimeSurvey Version 1.90+ Build 9642
Browser: IE7

Viele Grüße,
Sari

Please Log in to join the conversation.

More
5 years 5 months ago #65052 by holch
Wichtig wäre hier auch noch welches Template du verwendest und ob es ein Standard-Template ist oder ob es modifiziert wurde.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 5 months ago #65053 by holch
Ach ja: Kannst du denn das Problem unter IE7 nachvollziehen oder tritt es bei dir nicht auf?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 5 months ago #65061 by sari2108
Ich habe das Standardtemplate kopiert und modifiziert, so dass der Text über den Datenschutz kürzer ist und die Anzahl der Fragen nicht erscheint. Ich habe den IE 9, da tritt das Problem nicht auf, ich konnte es also nicht nachvollziehen.

Please Log in to join the conversation.

More
5 years 5 months ago #65065 by holch
Es kann schon mal passieren, dass bei einer Modifikation des Templates etwas auf der Strecke bleibt, aber deine Anpassungen hören sich eher unbedenklich an.

Ist natürlich schwer das Problem einzukreisen, wenn du nicht mit dem Browser testen kannst, bei dem das Problem auftaucht.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 5 months ago #65077 by c_schmitz
Sind evtl. Frage- oder Antworttexte aus Word kopiert worden?

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
5 years 5 months ago #65078 by sari2108
Ja, es kann schon sein, dass Fragen kopiert wurden. Kann ich jetzt aber nicht mehr nachvollziehen.
Ich habe die Umfrage jetzt mal mit IETester getestet und herausgefunden, dass es dieses Problem mit IE 7 und weniger gibt, ab 8 aber nicht mehr. Ein Kollege meinte, dass es an JavaScript liegen könnte. Was meint ihr? Gibt es da ein generelles Problem mit den Versionen?

Please Log in to join the conversation.

More
5 years 5 months ago #65079 by c_schmitz
Nein, gibt es nicht. Falls die Fragen aus Word kopiert worden, wird aber in der Seite ganz viel MS Trash HTML enthalten sein, welches zu HTML und Javascript Fehlern führt. Schau dir mal den Quelltext der fraglichen Seite ein, meistens ist das offensichtlich.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form