max_input_vars Fehler bei Umfrage, obwohl bereits konfig.

More
6 months 3 weeks ago - 6 months 3 weeks ago #174895 by holch
Welche Text-Datei? Wie gesagt, ich habe die Textdatei in Excel importiert, die Sprachen in zwei Spalten aufgeteilt und eine zusätzliche Answercode Spalte eingefügt. Dann alles direkt aus Excel heraus in bei "Quick Add" hinzugefügt. Der Vorteil: LS erkennt die Spalten direkt aus Excel und fügt schon die Answercodes und auch die zweite Sprache korrekt ein.

Die Excel-Datei war nur eine temporäre Datei, die ich nicht gespeichert habe (war ja nur ein Test). Müsste ich also erst neu erstellen.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last edit: 6 months 3 weeks ago by holch.

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #174902 by jelo

holch wrote: LS erkennt die Spalten direkt aus Excel und fügt schon die Answercodes und auch die zweite Sprache korrekt ein.

Das alles macht LS doch auch beim direkten Einfügen der Textdatei. Das Semikolon ist der Sprachseparator. Nur halt bei der Demo mit Fehler. Die Fehlermeldung deckt scheinbar mehrere Fälle ab. Demo sollte das können, dann wird die Fehlermeldung halt umgeschrieben ;-)

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #174904 by holch
Klar, aber ich wollte nicht noch mal die Excel-Datei als TXT-Datei exportieren und ging den schnellsten weg.

Habe das gerade mal in der Demo ausprobiert und ich bekomme die gleiche Fehlermeldung auf der Demo. In meiner Installation geht alles glatt und kann gespeichert werden.

Meine Schlussfolgerung: Entweder hat sich zwischen der Version 3.14.10 (Demo) und der Version 3.14.8+180829 (läuft zur Zeit auf meinem Server) etwas Grundlegendes verändert hat, oder (was ich für wesentlich wahrscheinlicher halte) es handelt sich um eine Servereinstellung.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #174912 by jelo

holch wrote: oder (was ich für wesentlich wahrscheinlicher halte) es handelt sich um eine Servereinstellung.

Ja, aber an den max_input_vars wird es wohl nicht hängen. Welchen Wert hast Du denn auf dem Server ;-)

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #174934 by jelo

fhbfiwien wrote: max_input_vars ist bereits auf 40000 gesetzt

Auch wenn ich einen anderen Fehler vermute, bitte mal auf einen höheren Wert 100000 setzen.
Und dann auch via phpinfo überprüfen, ob der Wert überhaupt in der PHP Umgebung von LimeSurvey ankommt.
Gibt auch Setups, wo es mehere php.ini Dateien gibt. Wäre also nicht ungewöhnlich, wenn die Werte aus Sicht von LimeSurvey sich nicht verändert haben.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #174941 by fhbfiwien
es hat sich erledigt, vielen dank, jetzt haben die 4000 max_input_vars doch funktioniert!

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!