Base centralisé - l'import ne fonctionne pas ?

More
3 years 2 months ago #109629 by riqcles
riqcles created the topic: Base centralisé - l'import ne fonctionne pas ?
:(
Bonjour,
j'ai essayé sur ma V2.05 dernière build, mais je n'arrive pas à importer des contacts dans la base centralisé.

J'ai aussi essayé sur le site de démo de LimeSurvey ==> meme constat.

D'autres peuvent confirmer ?

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

More
3 years 2 months ago #109640 by Nickko
Nickko replied the topic: Base centralisé - l'import ne fonctionne pas ?
Tu as regardé dans le bug tracker ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
3 years 2 months ago #109653 by riqcles
riqcles replied the topic: Base centralisé - l'import ne fonctionne pas ?
Mince !
ça existe :
bugs.limesurvey.org/view.php?id=8444

Je vais regarder les commentaires de Denis (encore en formation :) )

mais effectivement, j'ai exactement le même fonctionnement que KitchM

J'analyse, mais cela fonctionnait correctement en V2.00... :unsure:

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

More
3 years 2 months ago #109659 by DenisChenu
DenisChenu replied the topic: Base centralisé - l'import ne fonctionne pas ?
Moi c'est passé après le fix, mais avec un email non vide.

Tu peux repasser en bug mais avec un fichier KO ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 2 months ago #109671 by riqcles
riqcles replied the topic: Base centralisé - l'import ne fonctionne pas ?
alors j'ai essayé plusieurs méthode.
a partir du site de démo.

méthode 1 : utilisation du format proposé par la base centralisé

J'exporte le fichier csv, puis je supprime les enregistrements, sauf 1.
Apres, je refait l'import -> passe pas.
Je retente en supprimant l'information dans la colonne "participant_id" -> passe pas.

Methode 2 : utilisation d'un fichier d'invitation csv "classique"
J'importe avec toutes les colonnes -> passe pas
J'importe le fichier avec les 3 informations minimum :
firstname,lastname,email -> passe pas

J'ai mis les fichiers utilisés.
Si cela parait correct, je les rajoutes au mantis 8444 ?

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /
Attachments:

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #109684 by DenisChenu
DenisChenu replied the topic: Base centralisé - l'import ne fonctionne pas ?
Sur le premier pm,pm est étrange : mais cela devrait passer
Le 2 : cela devrait importer (si il n'existe pas) une ligne.
Le 3 : pareil que le 2.

La base d'origine est vide ?
Tu as des colonnes à statut obligatoire dans la base des participants ?

Denis
PS: oui, réouvre le mantis avec les 3 fichiers.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 2 months ago by DenisChenu.

Please Log in to join the conversation.

More
3 years 2 months ago #109692 by riqcles
riqcles replied the topic: Base centralisé - l'import ne fonctionne pas ?
Ok pour le Mantis, je vais rajouter les fichiers.

comme je suis en formation (jusqu'à mardi), je fais les tests sur l'environnment de démo de LimeSurvey

1.Sur le premier pm,pm est étrange : mais cela devrait passer --> J'ai fait un export de la base centrale du site de démo. les pm,pm sont normalement des attributs (Attribut management), mais dans le site, il n'y a aucun questionnaire qui utilise des tokens (donc pas de table d'invitation initialisé) -> à 11h07.

2 et 3 -> j'ai créé les infos, elles n'existe pas dans la base du site de démo (qui reste toujours à 29)

Tu as des colonnes à statut obligatoire dans la base des participants ? --> j'ai regardé dans Global participant setting, mais rien !

... pour le mantis, tu veux un commentaire ou juste les fichiers suffiront ?

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

Moderators: Nickko

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now