Captcha et jeton d'invitation

More
3 years 1 month ago #105271 by riqcles
Bonjour,
je ne sais pas si c'est un comportement normal (cela existe depuis la 1.85+ et j'ai testé avec le site de démo et la build 140217). :woohoo:

Lorsqu'on a un questionnaire avec invitation, si on active le captcha sur l'accès au questionnaire,
lors de l'accès au questionnaire en utilisant l'url d'invitation (ou en choississant de remplir à partir de la partie administration des invitations), une page s'affiche avec :

Le texte qui indique qu'on doit avoir une invitation valide pour participer
le jeton d'invitation en "clair"
le captcha qui est en attente de saisie.

A votre avis ? normal ou pas ? :ohmy:

LimeSurvey version 2.05 build 141020 / 2.00 + build 131107 / 1.85+ (hors service ! yes ! )
OS : CentOS 6.5 / PHP 5.4.33/ 5.3.13
BDD : PostGresql 9.3.4 / 9.3.1 / 8.4.11
Attachments:

Please Log in to join the conversation.

More
3 years 1 month ago #105298 by DenisChenu
Salut,

En même temps le jeton est en clair dans le lien . C'est pas très sécure non plus.

Dans le formulaire par défaut, il me semble qu'il est type='password', donc à voir.

Je sais pas trop là, remonte le bug, d'autres auront peut être un avis. Mais en tous cas, c'est pas 'major', puisque le lien indique le code aussi.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 month ago #105313 by riqcles
Salut,
j'ai créé le bug dans le tracker :
bugs.limesurvey.org/view.php?id=8743

LimeSurvey version 2.05 build 141020 / 2.00 + build 131107 / 1.85+ (hors service ! yes ! )
OS : CentOS 6.5 / PHP 5.4.33/ 5.3.13
BDD : PostGresql 9.3.4 / 9.3.1 / 8.4.11

Please Log in to join the conversation.

Moderators: Nickko