Check out the LimeSurvey source code on GitHub!

problème envoi de mails

More
3 years 3 days ago #105151 by lessources
Bonjour,
je viens d'installer lime Version 2.05+ Build 140217 sur un serveur centos 6.5.
et je souhaite configurer l'envoi de mails.
si j'envoie un mail via webmin ou directement via le serveur, ça fonctionne. (mon serveur smtp distant relaie bien le mail)
malheureusement quelle que soit la methode configurée dasn lime, j'ai systématiquement un refus:
- methode PHP :L'envoi du courriel à Array a échoué. Message d'erreur : Impossible d'instancier la fonction mail.
- METHODE SMTP: L'envoi du courriel à Array a échoué. Message d'erreur : Erreur SMTP : Impossible de se connecter au serveur SMTP.
- methode sendmail: L'envoi du courriel à Array a échoué. Message d'erreur : Impossible de lancer l'exécution : /usr/sbin/sendmail

j'y perds mon latin!
quelqu'un aurait-il déja rencontré ce problème?

merci d'avance pour votre aide

Please Log in to join the conversation.

More
3 years 3 days ago #105153 by Nickko
Est-ce que tu es sûr que le port de ton serveur SMTP est autorisé en sortie par ton serveur web ?
Il y a manifestement un lien qui ne se fait pas entre le serveur web et le serveur SMTP, puisque le SMTP fonctionne, il est fort possible que le problème vienne su serveur web.

Nickko

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
3 years 3 days ago #105155 by lessources
je ne comprends pas ou configurer sur le serveur web (j'entends par là Apache) l'autorisation de sortie sur le port 25.
pour info iptables est désactivé et l'envoi de mail via la ligne de commande fonctionne.

Please Log in to join the conversation.

More
3 years 3 days ago #105156 by lessources
voici le message reçu quand je fais mon test depuis webmin:

This is a test message from Webmin, sent with the settings :

Mail server: Mail server: Sendmail
Sent via: srvcpsure.dsources.local
SMTP login: None
SMTP authentication: Default

ce qui confirme que mon sendmail est bien configuré sur la machine

Please Log in to join the conversation.

More
3 years 3 days ago #105168 by Nickko
Pour Apache, tu as un peu d'expérience en administration serveur ?
Sinon opte pour un hébergement mutualisé, ça t'éviter ce genre de déconvenues.

Pour Apache, j'aurais dit dans le fichier httpd mais je n'en sais pas plus.

Pour la fonction mail, on dirait qu'elle n'est pas activée / installée. C'est bizarre, et ça dépasse un peu mon niveau de connaissance.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
3 years 3 days ago #105174 by DenisChenu
Salut,

C'est pas parceque webmin peut utiliser sendmail que php le peux ....

Fait un "which sendmail" et reconfigure ton php.ini peut être.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: lessources

Please Log in to join the conversation.

More
3 years 3 days ago #105176 by lessources
plusieurs soucis se cumulaient:
- selinux était actif
- le smart relay mal configuré dans sendmail.

merci pour votre aide
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
3 years 2 days ago #105180 by DenisChenu
SeLinux .... :unsure:

C'est bien, mais cela demande plus de réglages ...

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form