PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00

More
3 years 8 months ago #100456 by riqcles
riqcles created the topic: PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00
Bonjour à tous, J'ai un bug lors de l'import de questionnaires réalisé dans la V1.85+ (avec BDD Postgres) dans une V2 (build 130929 et antérieur) aussi sous BDD Postgres.

J'ai le message d'erreur suivant :
Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42883]: Undefined function: 7 ERREUR: la fonction last_insert_id() n'existe pas
LINE 1: Select LAST_INSERT_ID()
^
HINT: Aucune fonction ne correspond au nom donné et aux types d'arguments.
Vous devez ajouter des conversions explicites de type.

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.


Au moins le français fonctionne ! :laugh:

Si j'importe le questionnaire 1.85 dans une version 2.00 avec une BDD sous Mysql (exemple : le site de démo de Limesurvey / ou une installation sous Easyphp), il n'y a pas d'erreur.

J'ai regardé dans le Mantis -> pas trouvé d'erreur en relation.
J'ai pas essayé avec la première version de la V2 qui était sorti juste après la 1.92.. (je regarde si je l'ai sous le coude !) pour tester et comparer le code Yii.

J'attache le questionnaire, si ceux qui ont un postgres peuvent tester pour confirmer l'erreur avant création d'un Mantis

Merci :P

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /
Attachments:

Please Log in to join the conversation.

More
3 years 8 months ago #100457 by DenisChenu
DenisChenu replied the topic: PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00
Attend pas,

C'est bien dans la fonction CSVimport:
$newlid=Yii::app()->db->createCommand('Select LAST_INSERT_ID()')->query()->read();

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 8 months ago #100470 by riqcles
riqcles replied the topic: PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00
:laugh:
Ok c'est soumis : bugs.limesurvey.org/view.php?id=8235

Merci :)

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

More
3 years 8 months ago #100580 by DenisChenu
DenisChenu replied the topic: PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00
Et fixé par Carsten :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: riqcles

Please Log in to join the conversation.

More
3 years 8 months ago #100596 by riqcles
riqcles replied the topic: PostrgeSQL 9.1 - Importer questionnaire csv 1.85+ vers 2.00
:woohoo: Super !
je vais télécharger la nouvelle version de ce pas.

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now