Echec mise à jour v1.90+ b9290 à 2.0 b130708

More
3 years 8 months ago - 3 years 8 months ago #98108 by yannick01
Bonjour,

Après avoir cherché un moment, j'ai un problème de migration entre ma version 1.9 et la 2.0, ce problème semble être lié à ma volumétrie de données (350 questionnaires) ou aux données elles mêmes. Les tests réalisés sur mon environnement avec des bases vierges passent sans problèmes.

Lorsque je déroule l'assistant web de migration, j'arrive à la page ou j'ai ce message : The LimeSurvey database is being upgraded (2013-07-16 15:53:14) .... Les points s'affichent montrant la progression, j'ai de la charge sur le mysql, puis quelques minutes après plus rien et la progression s'arrête....

J'ai bien posé mon fichier config.php et suivi la doc mais j'aimerais savoir ou trouver la trace de la mise à jour, je peux passer en débug qqpart ? J'aimerais voir ce qui bloque ?

Merci
Yannick

PS: Voici mes derniers logs SQL du serveur :

435 Query ALTER TABLE `lime_surveys_languagesettings` CHANGE `surveyls_endtext` `surveyls_endtext` text
435 Query ALTER TABLE `lime_user_groups` CHANGE `description` `description` text NOT NULL
435 Query ALTER TABLE `lime_conditions` CHANGE `value` `value` varchar(255) NOT NULL DEFAULT ''
130716 16:46:49 435 Query ALTER TABLE `lime_participant_shares` CHANGE `can_edit` `can_edit` varchar(5) NOT NULL
435 Query ALTER TABLE `lime_users` CHANGE `password` `password` blob NOT NULL
435 Query ALTER TABLE `lime_users` DROP COLUMN `one_time_pw`
130716 16:46:50 435 Query ALTER TABLE `lime_users` ADD `one_time_pw` blob
435 Query UPDATE `lime_question_attributes` SET `value`='1' WHERE attribute = 'random_order' and value = '2'
435 Query UPDATE `lime_settings_global` SET `stg_value`='157' WHERE stg_name='DBVersion'
435 Query select distinct a.qid, a.attribute, a.value from lime_question_attributes as a, lime_questions as b where a.qid=b.qid order by a.qid, a.attribute
130716 16:47:06 435 Query rollback
435 Quit
Last Edit: 3 years 8 months ago by yannick01.

Please Log in to join the conversation.

More
3 years 8 months ago #98126 by DenisChenu

yannick wrote: Lorsque je déroule l'assistant web de migration, j'arrive à la page ou j'ai ce message : The LimeSurvey database is being upgraded (2013-07-16 15:53:14) .... Les points s'affichent montrant la progression, j'ai de la charge sur le mysql, puis quelques minutes après plus rien et la progression s'arrête....

La mémoire allouée à PHP, voire le temps alloué pour les scripts PHP.

Ce que je fais quelquefois c'est poussé la mémoire au max pour la mise à jour et tenter le coup.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Moderators: Nickko