Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Problème de langue des modèles de courriels d'invitation

Problème de langue des modèles de courriels d'invitation 3 years 4 months ago #94977

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Bonjour,

J'utilise Limesurvey 1.92 et observe un problème avec la langue des courriels d'invitation : alors que mon interface est en français, que la langue par défaut définie dans les paramètres de l'application est le français, les corps des messages de notification sont en anglais (alors que le sujet est en français).

J'ai donc téléchargé sur www.limesurvey.org/translationstatus192/ les dernières versions des fichiers fr.mo et fr.po et les ai placés dans locale/fr/LC_MESSAGES/... sans résultat.

Constatez vous le même comportement de votre côté ?

Avez vous réussi à résoudre ce problème ? Comment ?

Par avance, merci pour votre aide !
Nicolas
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 4 months ago #94979

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2789
  • Thank you received: 365
  • Karma: 78
La v1.92 est déjà ancienne, je n'ai pas encore eu vent du problème que tu rencontres, mais peut-être était-ce un bug résolu depuis.

Pour en avoir le cœur net, tu peux soit consulter le bug tracker soit essayer la v2.00 directement.

Nickko
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.
The following user(s) said Thank You: nicktruch

Problème de langue des modèles de courriels d'invitation 3 years 4 months ago #95123

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Salut,

Ce sont les textes par défaut, un problème de quote mal reconnu. Placer son propre message sur les modèles des mails pour le questionnaire règle le problème.

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 4 months ago #95167

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Bonjour Denis,

Je n'ai pas compris :
- de quel problème de quote parles-tu ? Puis-je intervenir dessus ?
- quand tu parles des modèles de mail, tu parles des modèles proposés dans le backoffice ou dans le fichier fr.po ?

S'il s'agit de ceux dans le backoffice, cela ne répond pas à mon problème car je ne vais pas être le seul administrateur et à moins de leur proposer un modèle en français qu'ils puissent copier-coller, le fait que la notification leur soit proposée en anglais risque de poser problème.

Merci pour ton aide précieuse,
Nicolas
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95355

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Salut,
nicktruch wrote:
S'il s'agit de ceux dans le backoffice, cela ne répond pas à mon problème car je ne vais pas être le seul administrateur et à moins de leur proposer un modèle en français qu'ils puissent copier-coller, le fait que la notification leur soit proposée en anglais risque de poser problème.
Non, pas réalisable directement via fr.po, justement les quotes(") sont la reconnus dans la dernière version 1.92.

Ton installation est monolingue ?
Si oui : le plus simple: modifier directemnt les textes par défaut dans admin/admin_functions.php.

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95361

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Bonjour,

Merci Denis pour ta réponse,
Oui mon installation est monolingue (enfin je n'ai pas l'utilité de plusieurs langues).

J'ai essayé d'accéder à l'adresse indiquée mais j'obtiens une page blanche... Le code source est tout autant vide alors que le fichier est bien présent dans l'arborescence et que les droits dessus sont bien réglés...

Any idea ?

Nicolas
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95362

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Désolé, je n'avais pas compris qu'il fallait éditer le fichier et non y accéder. Je vais voir ce que je peux faire.

Nicolas
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95364

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Oui, éditer le code source du fichier PHP ;)

Cherche avec Dear { , il me semble que touts les message commencent comme cela.

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95411

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Bonjour,

J'ai édité une des lignes correspondant à l'un des modèles de courriel "Invitation" :

'invitation'=>$oLanguage->gT("Cher(e) {FIRSTNAME},\n\nVous avez été invité à participer à un questionnaire.\n\nCelui-ci est intitulé :\n\"{SURVEYNAME}\"\n\n\"{SURVEYDESCRIPTION}\"\n\nPour participer, veuillez cliquer sur le lien ci-dessous.\n\nCordialement,\n\n{ADMINNAME} ({ADMINEMAIL})\n\n----------------------------------------------\nCliquez ici pour remplir ce questionnaire :\n{SURVEYURL}",$mode)."\n\n".$oLanguage->gT("Si vous ne souhaitez pas participer à ce questionnaire et ne souhaitez plus recevoir aucune invitation, veuillez cliquer sur le lien suivant :\n{OPTOUTURL}",$mode),

Lorsque je retourne dans les modèles de courriels proposés, la proposée pour le corps du message est toujours l'anglais...

Que pasa ?

Nicolas
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95417

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
C'est quand tu va créer un nouveau questionnaire, les anciens modèles ne sont pas modifiés pour reprendre le texte par défaut.

Ca serait dailleurs une bonne idée de ne pas sauvegarder le texte par défaut, mais pas prévu actuellement.

Essaye en cliquant sur "Par défaut".

Denis
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Problème de langue des modèles de courriels d'invitation 3 years 3 months ago #95425

  • nicktruch
  • nicktruch's Avatar
  • Offline
  • Junior Lime
  • Posts: 28
  • Karma: 0
Parfait !

ça marche nickel en cliquant sur "Par défaut".

Au cas où cela intéresse quelqu'un, voici les lignes modifiées (lignes 301 à 310) :
'admin_notification_subject'=>$oLanguage->gT("Response submission for survey {SURVEYNAME}",$mode),
'admin_notification'=>$oLanguage->gT("Bonjour,\n\nUne nouvelle réponse a été soumise pour votre questionnaire '{SURVEYNAME}'.\n\nCliquer sur le lien suivant pour recharger votre questionnaire :\n{RELOADURL}\n\nCliquer sur le lien suivant pour voir la réponse :\n{VIEWRESPONSEURL}\n\nCliquer sur le lien suivant pour éditer la réponse :\n{EDITRESPONSEURL}\n\nVisualisez les statistiques en cliquant ici :\n{STATISTICSURL}",$mode),
'confirmation_subject'=>$oLanguage->gT("Confirmation of your participation in our survey"),
'confirmation'=>$oLanguage->gT("Cher(e) {FIRSTNAME},\n\nCe courriel vous confirme que vous avez complété le questionnaire intitulé {SURVEYNAME} et que votre réponse a été enregistrée. Merci pour votre participation.\n\nSi vous avez des questions à propos de ce courriel, veuillez contacter {ADMINNAME} à l’adresse {ADMINEMAIL}.\n\nCordialement,\n\n{ADMINNAME}",$mode),
'invitation_subject'=>$oLanguage->gT("Invitation to participate in a survey",$mode),
'invitation'=>$oLanguage->gT("Cher(e) {FIRSTNAME},\n\nVous avez été invité à participer à un questionnaire.\n\nCelui-ci est intitulé :\n\"{SURVEYNAME}\"\n\n\"{SURVEYDESCRIPTION}\"\n\nPour participer, veuillez cliquer sur le lien ci-dessous.\n\nCordialement,\n\n{ADMINNAME} ({ADMINEMAIL})\n\n----------------------------------------------\nCliquez ici pour remplir ce questionnaire :\n{SURVEYURL}",$mode)."\n\n".$oLanguage->gT("Si vous ne souhaitez pas participer à ce questionnaire et ne souhaitez plus recevoir aucune invitation, veuillez cliquer sur le lien suivant :\n{OPTOUTURL}",$mode),
'reminder_subject'=>$oLanguage->gT("Reminder to participate in a survey",$mode),
'reminder'=>$oLanguage->gT("Cher(e) {FIRSTNAME},\n\nVous avez été invité à participer à un questionnaire récemment.\n\nNous avons pris en compte que vous n'avez pas encore complété le questionnaire, et nous vous rappelons que celui-ci est toujours disponible si vous souhaitez participer.\n\nLe questionnaire est intitulé :\n\"{SURVEYNAME}\"\n\n\"{SURVEYDESCRIPTION}\"\n\nPour participer, veuillez cliquer sur le lien ci-dessous.\n\Cordialement,\n\n{ADMINNAME} ({ADMINEMAIL})\n\n----------------------------------------------\nCliquez ici pour accéder au questionnaire :\n{SURVEYURL}",$mode)."\n\n".$oLanguage->gT("Si vous ne souhaitez pas participer à ce questionnaire et ne souhaitez plus recevoir aucune invitation, veuillez cliquer sur le lien suivant :\n{OPTOUTURL}",$mode),
'registration_subject'=>$oLanguage->gT("Survey registration confirmation",$mode),
'registration'=>$oLanguage->gT("Cher(e) {FIRSTNAME},\n\nVous (ou quelqu’un utilisant votre adresse électronique) vous êtes enregistré pour participer à un questionnaire en ligne intitulé {SURVEYNAME}.\n\nPour compléter ce questionnaire, cliquez sur le lien suivant :\n\n{SURVEYURL}\n\nSi vous avez des questions à propos de ce questionnaire, ou si vous ne vous êtes pas enregistré pour participer à celui-ci et croyez que ce courriel est une erreur, veuillez contacter {ADMINNAME} à l’adresse {ADMINEMAIL}.",$mode)

Merci encore Denis, une fois de plus !

Bien à vous,
Nicolas
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.380 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form