Bug export de données - Invalid object name 'lime_survey_22814_timings'

More
4 years 1 day ago #94221 by mascarpone
Bonjour,

J'ai tenté ce matin d'exporter les données d'une de mes enquêtes, mais l'export bug: le fichier xls ou csv est créé, mais s'ouvre avec le message d'erreur suivant:

Invalid object name 'lime_survey_22814_timings'.:SELECT [lime_survey_22814].[id], [submitdate], [lastpage], [startlanguage], [datestamp], [startdate], [22814X459X4201], [22814X459X4202], [22814X459X4203], [22814X459X4204], [22814X459X4205], [22814X459X4206], [22814X459X4207], [22814X446X4166], [22814X446X4167], [22814X446X4208], [22814X446X4169], [22814X446X4168], [22814X446X4170], [22814X447X4171], [22814X447X4172], [22814X447X4209], [22814X447X4173], [22814X448X4174], [22814X448X4175], [22814X448X4176], [22814X449X4200], [22814X449X41771], [22814X449X41772], [22814X449X41773], [22814X449X41774], [22814X449X41775], [22814X449X41781], [22814X449X41782], [22814X449X41783], [22814X449X41784], [22814X449X41785], [22814X449X41786], [22814X449X41787], [22814X449X41788], [22814X450X4179], [22814X450X4180], [22814X451X4181], [22814X451X4182], [22814X452X4183], [22814X453X4185], [22814X453X4184], [22814X453X4186], [22814X453X4187], [22814X454X4188], [22814X455X4189], [22814X455X4190], [22814X456X4192], [22814X456X4191], [22814X456X4210], [22814X456X4193], [22814X457X4194], [22814X457X4195], [22814X457X4196], [22814X458X4197], [22814X458X4198], [22814X458X4199], [interviewtime], [22814X459time], [22814X459X4201time], [22814X459X4202time], [22814X459X4203time], [22814X459X4204time], [22814X459X4205time], [22814X459X4206time], [22814X459X4207time], [22814X446time], [22814X446X4166time], [22814X446X4167time], [22814X446X4208time], [22814X446X4169time], [22814X446X4168time], [22814X446X4170time], [22814X447time], [22814X447X4171time], [22814X447X4172time], [22814X447X4209time], [22814X447X4173time], [22814X448time], [22814X448X4174time], [22814X448X4175time], [22814X448X4176time], [22814X449time], [22814X449X4200time], [22814X449X4177time], [22814X449X4178time], [22814X450time], [22814X450X4179time], [22814X450X4180time], [22814X451time], [22814X451X4181time], [22814X451X4182time], [22814X452time], [22814X452X4183time], [22814X453time], [22814X453X4185time], [22814X453X4184time], [22814X453X4186time], [22814X453X4187time], [22814X454time], [22814X454X4188time], [22814X455time], [22814X455X4189time], [22814X455X4190time], [22814X456time], [22814X456X4192time], [22814X456X4191time], [22814X456X4210time], [22814X456X4193time], [22814X457time], [22814X457X4194time], [22814X457X4195time], [22814X457X4196time], [22814X458time], [22814X458X4197time], [22814X458X4198time], [22814X458X4199time] FROM lime_survey_22814 LEFT OUTER JOIN lime_survey_22814_timings ON lime_survey_22814.id = lime_survey_22814_timings.id LEFT OUTER JOIN lime_tokens_22814 ON lime_survey_22814.token = lime_tokens_22814.token

J'ai fais quelques recherche et ai vu qu'il y avait d'autre problème d'export rapportés, mais rien qui ressemble à ca, pour ce que j'en comprends du moins.

J'ai tenté d'exporter les données d'une autre enquête (montée sur cette meme instance de LS) sans problème!

Une idée?

Merci!

Please Log in to join the conversation.

More
4 years 1 day ago #94227 by DenisChenu
Salut,

Le problème n'intervient que sur les questionnaire avec "Sauvegarder les chronométrages ?" à OUI ?

Si ce questionnaire a bien Sauvegarder les chronométrages ? à OUI, vérifie que la table correspondante existe.
Si elle n'existe pas : tente une "vérification de l'intégrité des données"

A vérifier:
Création d'un questionnaire avec, activer le questionnaire, répondre une fois, tenter l'export des données: si ca ne passe pas, que tu es sur la dernière version : rapport de bug.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: mascarpone

Please Log in to join the conversation.

More
3 years 10 months ago #95781 by mascarpone
Bonjour à tous, je voulais juste te remercier pour ton soutien Denis!

Le souci existe toujours, mais j'ai depuis attaqué une transition vers 2.00+ qui me demande pas mal de temps. Jusqu'ici les BD (MS SQL) étaient de plus gérées par un tiers ce qui m'a empêchés de suivre tes propositions (vérifier la présence de la table timings, etc.). Je m'attèle aussi à cette partie du travail désormais et j'espère pouvoir revenir sur ce problème bientôt (s'il subsiste dans 2.00+ :) ).

Please Log in to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #96153 by mascarpone
Juste pour poursuivre ce fil et le conclure. Une solution (meme si un peu bricolage) trouvée sur un autre fil ( www.limesurvey.org/en/forum/can-i-do-thi...y-deactivated-survey ):

Mon problème concernant cet export était lié au fait que je souhaitais exporter les "full answers" (et donc accéder à la table dans la DB directement ne m'était d'aucune utilité).

Finalement j'ai désactivé l'enquête, puis je l'ai réactivée (en ayant pris soin de ne pas demander à ce que les "timings" soient enregistrés cette fois). Puis:

1. click "responses & statistics"
2. "import responses from a deactivated survey table"
3. la bonne table m'a été proposée par défaut (nb: j'avais pris soin de sauvegarder le nom de la table au cas ou au moment de la desactivation)
4. valider

Sauvé, j'ai pu tout exporter en "full answers"
Last Edit: 3 years 10 months ago by mascarpone.

Please Log in to join the conversation.

More
3 years 10 months ago #96156 by DenisChenu
Salut,

Il semble bien y avoir un bug avec les timings alors ?
Je ne m'en sert quasiment jamais de mon coté.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Moderators: Nickko