PERTE DES IDENTIFIANTS DE SAUVEGARDE

More
4 years 1 month ago #93117 by airicarus01
Bonjour à tous,

Contexte :
Limesurvey / Version 1.80+ (6579)
RedHat / 5.0


Nous avons communiqué sur un très gros sondage de plus de 700 questions.
Il était important de vérifier que la fonction Sauvegarde fonctionne.
Il s'avère que ce n'est pas le cas.

Les lignes d'enregistrement de la table "_saved_control" disparaissent, les utilisateurs ne peuvent reprendre à partir de leur sauvegarde. Par contre , les réponses sont bien présentes en base de données.

Pour récupérer les réponses déjà saisies , nous avons réinjecté les lignes correspondantes dans la table et communiqué à nouveaux aux utilisateurs.

-- ***********************************
-- ***** insert to restore saves *****
-- ***********************************
-- `scid` : is auto_increment
-- `sid` : is the ID for the survey
-- `srid` : is the response line (see admin panel for uncomplete response)
-- `identifier` : will be the login to restore the response
-- `access_code` : is the encrypted password to restore the response (create a response and save to have a known encrypted password)
-- `saved_thisstep` : page number to restore (let 1, user will click on [Next] button to retrieve last anwser)
-- `status` : not known => let 'S'
-- `email`, `ip`, `saved_date`, `refurl` : not important
-- ***********************************

Etes vous au courant de ce problème ?

Cordialement

Please Log in to join the conversation.

More
4 years 3 weeks ago #93272 by DenisChenu
Salut,

Je n'ai plus aucune connaissance des probème de la version 1.80.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 3 weeks ago - 4 years 3 weeks ago #93316 by airicarus01
je ne suis pas sûr que ce soit un probleme lié à la version 1.80 , mais encore hier, j'ai du ajouter manuellement un enregistrement pour dépanner un utilisateur.

INSERT INTO `lsadeo_saved_control` (`scid`, `sid`, `srid`, `identifier`, `access_code`, `email`, `ip`, `saved_thisstep`, `status`, `saved_date`, `refurl`) VALUES
( ...... ) ;
Last Edit: 4 years 3 weeks ago by airicarus01.

Please Log in to join the conversation.

More
4 years 3 weeks ago #93352 by DenisChenu
Si le problème est résolu sur une version future, je ne vois pas comment on pourrait t'aider. Comme il n'y a pas de bug ouvert sur ce thème et que beaucoup de personnes utilisent cette fonction, je suppose que c'est corrigé.

Tu peux aussi contacter un professionnel : www.limesurvey.com/ ou moi même .

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 1 week ago #94124 by riqcles
Bonsoir,
J'avais un problème de sauvegarde en version 1.85+. Après l'envoi des invitations, si je laissait une adresse email dans le bounce, lorsque la personne réalisait sa sauvegarde, il ne recevait pas un email qui lui indique ses identifiants de sauvegardes.

Si cela peut t'aider.

Le bounce se trouve dans les paramètres du questionnaire.

LimeSurvey version 2.06 build 141020 / future 2.62 / 63 build dernière en date :)
OS : CentOS 7.1 / PHP 5.6.27
BDD : PostGresql 9.4.6 /

Please Log in to join the conversation.

Moderators: Nickko