Welcome, Guest
Username: Password: Remember me

TOPIC: Bug internet explorer

Bug internet explorer 3 years 2 months ago #88696

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
Bonjour,

J'ai envoyé mon questionnaire ce matin à quelques 1000 répondants et j'ai reçu passablement de mail en retour comme quoi ils ne pouvaient pas passer à la page 2 lorsqu'ils cliquent sur "suivant". Il y a alors cela qui apparait: "message d'erreur sur la page".

Après avoir pris quelques renseignements, je me suis rendu compte que c'était seulement ceux qui utilisaient Internet explorer qui rencontraient ce problème...

Il y a donc certainement une erreur de script sur la page, mais comme je n'ai pas vraiment de compétences informatiques, autant dire que je cherche une aiguille dans une meule de fois, sans même savoir ce qu'est une aiguille!

Quelqu'un pourrait-il m'aider à résoudre ce problème?

D'avance merci!
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88699

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
Bonjour,
Cela s'apparente plus à un pb de ressources serveur ... Tu as déjà des répondants complets à ton enquête ?
Pour en savoir plus, quelle est ta version de LS ? Hébergement ? Dans ton questionnaire y-a-t-il bcp de conditionnements ?

A+

Thibault
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88702

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
Bonjour,
Oui j'ai déjà des réponses complètes.
La version est la 1.91 (+ Build 120302)
L'hébergement: "Serveur LimeSurvey Faculté des SSP - Université de Lausanne"
J'ai effectivement passablement de conditions.

Merci
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88707

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
Quel est exactement le message d'erreur que tu as ?
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88708

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
"erreur sur la page"
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88709

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
euh ... c'est dur de savoir d'où cela peut venir. Tu peux faire une copie d'écran ou peut on accéder à une version test de ce questionnaire ?
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88712

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
Oui pas de problème...
Voilà le lien vers une version test (mais qui est identique à la version originale):
sphinx2.unil.ch/index.php?sid=18346&lang=fr
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88713

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
Peux tu activer ton questionnaire ?
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88715

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
Oui pardon, c'est fait.
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88718

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
ah oui effectivement ... peut être que cela vient de la version de LS que tu utilises (assez ancienne maintenant)... Je n'ai pas assez de recul sur ça ... DEnis t'en diras plus .. Pour être sûr, installes toi Limesurvey sur un serveur virtuel local (type easy php ... ) avec par exemple une version 1.92, exporter et reimporter ton questionnaire, et voir si en local cela vient de ta version.
Si ça vient de là, il faudra peut être pensé à une montée de version ...

Thibault
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88719

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
La version de LS, comme le serveur sur lequel je travaille me sont mis à disposition par mon employeur, je ne peux donc malheureusement pas changer cela.

Par contre n'y a-t-il pas moyen de modifier qqch dans le questionnaire (dans le script) pour que cela fonctionne? Tu me parlais de conditionnements? Cela peut-il en être la cause?
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88721

  • titoun31
  • titoun31's Avatar
  • Offline
  • Expert Lime
  • Posts: 107
  • Thank you received: 13
  • Karma: 6
Ben sur Firefox ton questionnaire fonctionne apparemment bien ... donc c'est vraiment un BUG de IE : où je ne sais pas (je ne suis pas suffisamment calé...). Il faut que regardes sur ce forum et sur le bug tracker, ceux qui ont dû avoir le même pb que toi il y a plusieurs mois ... parce que tu n'as pas ajouté de javascript "pourri" dans ton questionnaire, les conditions fonctionne sous Firefox et Chrome, il n'y a pas de pb de ressources etc

Le soucis pour toi se sont les MAJ de LS et si tu n'as pas accès aux fichiers, ça risque d'être compliqué pour toi ...
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88724

  • dinette
  • dinette's Avatar
  • Offline
  • Senior Lime
  • Posts: 45
  • Karma: 0
Merci pour tes remarques Thibault.
Denis va me répondre directement ici ou dois-je le solliciter différemment?
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88738

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2654
  • Thank you received: 343
  • Karma: 77
Je pense qu'il faut signaler le problème à ton employeur et que ça va justifier une mise à jour.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Bug internet explorer 3 years 2 months ago #88822

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 8195
  • Thank you received: 1119
  • Karma: 331
dinette wrote:
Merci pour tes remarques Thibault.
Denis va me répondre directement ici ou dois-je le solliciter différemment?
Salut,

Heu .... pas d'idée là ... (et puis je sui bénévole ic

EN plus le questionnaire n'est pas actif. Mais ce n'est pas un type de bug que je connais. La seule fois ou je me rappelle ce genre de truc c'est avec des proxy sur la connexion internet.

Denis
PS1: je suis bénévole sur LS, pas mal de patch pour la version 2 actuellement.
PS2: en cas d'urgence : assistance professionnelle : www.sondages.pro/contact.html
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.163 seconds