[2.00+] [STATS] Non prise en compte de "Ss-totaux basés sur les qu. affichées"

More
4 years 4 months ago - 4 years 4 months ago #87638 by Qat
Hello,

Avant de soumettre un rapport de bug, j'aimerais savoir si d'autres que moi ont un problème similaire, ou si j'ai juste mal compris cette option:

Dans le module Statistiques, l'option "Sous-totaux basés sur les questions affichées" semble ne pas fonctionner avec les questions QCM. Je m'explique.

Imaginons une première question Q1 de type OUI/NON.
La question Q2 est une question à choix multiples (A,B,C,D), mais ne s'affiche que si Q1 = OUI.

Le premier répondant répond non à Q1
Le second répondant, répond OUI, et choisit A & B
Le troisième répondant répond OUI, et choisit A & D

Résultat attendu pour la question 2 dans les stats avec l'option "Sous-totaux basés sur les questions affichées" :

A : 100 % (100% de ceux qui ont vu la question ont choisi A)
B : 50% (50% de ceux qui ont vu la question ont choisi B )
C : 0% (personne n'a choisi C)
D : 50% (50% de ceux qui ont vu la question ont choisi D)

Or, j'obtiens
A : 66% %
B :33%%
C : 0%
D : 33%%
Ce qui correspond aux statistiques sans l'option "Sous-totaux basés sur les questions affichées"

[attachment:1]LS2_StatGlitch.png[/attachment]

Vous pouvez m'éclairer sur ce point ? Merci !
Attachments:
Last Edit: 4 years 4 months ago by Qat. Reason: Fichu smiley intempestif !

Please Log in to join the conversation.

More
4 years 4 months ago #87674 by DenisChenu
Salut,

Cela me semble bien être un bug. Le mieux pour le rapport de bug : le questionnaire au format lss, voire au format lsa !

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Moderators: Nickko