Problème lors de l'exportation des réponses sous excel apparu avec la version 2

More
5 years 1 month ago - 5 years 1 month ago #86961 by FabienO
FabienO created the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Bonjour à tous,

Alors voilà presque tout est dans le titre, je suis passé à la version 2 et là un problème a fait son apparition lors de l'exportation des réponses, je vous explique :

Dans la page "Donner les statistique de ces réponses", je sélectionne les groupes de questions à exporter, je choisi le format "excel" et j'appuie sur "afficher les stats". C'est à ce moment que j'obtiens cette page d'erreur :

Firefox ne peut trouver le fichier à l'adresse http://
(je ne transmet pas l'adresse du serveur)/index.php/admin/statistics/index/surveyid/838218#start.

Vérifiez la syntaxe du nom de fichier (dont le respect des minuscules/majuscules) ;
Vérifiez si le fichier n'a pas été déplacé, renommé ou supprimé.

Même problème avec Chrome.
Par contre si je ne sélectionne aucun groupe de question le fichier excel se télécharge normalement (mais vide).

Pourriez-vous m'aider?
Last Edit: 5 years 1 month ago by FabienO. Reason: présentation

Please Log in to join the conversation.

More
5 years 1 month ago #86966 by Ben_V
Ben_V replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Fabien,
il y a un rapport de bug à ce sujet

Ben

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: FabienO

Please Log in to join the conversation.

More
5 years 1 month ago #86984 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Bonjour Ben,

Je ne reconnais pas mon problème dans ce rapport de bug. En effet, dans mon cas je n'arrive même pas à télécharger le fichier excel, ma page internet me met cette erreur :



Fabien

Please Log in to join the conversation.

More
5 years 1 month ago #86987 by Ben_V
Ben_V replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Oui visiblement c'est encore autre chose... :(

Bon j'ai essayé ce que tu décris sur la version que j'ai en local et je n'ai pas ce problême, juste que le .xls téléchargé est vide.... Visiblement tu as un problême supplémentaire vu ton message d'erreur....
Sinon l'export normal sans filtrer vers excel fonctionne bien, c'est déjà çà!

J'ai vu qu'il y a une mise à jour et j'essaierai une fois celle-ci faîte pour voir si j'arrive à télécharger des résultats filtrés...

Ben/

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: FabienO

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #86991 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Oui c'est cela, lors de l'exportation, le fait d'aller chercher les résultats aux réponses fait apparaître le message d'erreur.

Par contre, je me suis mal exprimé dans mon premier message car je n'arrive pas du tout à exporter les réponses sous excel que ce soit avec ou sans filtre...

J'arrive à télécharger un fichier excel uniquement lorsque que je sélectionne aucune réponse ou aucun filtre. Dans ce cas, j'ai juste le fichier excel avec dedans :

"Nombre d'enregistrement(s) pour cette requête : ..
Nombre total d'enregistrements pour ce questionnaire : ..
Pourcentage du total : ..."

Serait-ce un problème lors de l'accès à la base de donnée?

Fab
Last Edit: 5 years 1 month ago by FabienO.

Please Log in to join the conversation.

More
5 years 1 month ago #87010 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Je reviens car j'ai effectué d'autres tests...

-J'ai installé la version en local et là mon export se passe bien mais je retombe sur le bug du rapport que tu as cité dans ton premier post.

-Avec limesurvey installé sur le serveur (non local), j'ai réussi à exporter mes résultats mais via "exporter les résultats dans une application". Tout se passe bien. Le problème est que j'ai réalisé une macro pour exploiter tous mes futurs résultats (entre 150 et 200 enquêtes) qui se base sur l'autre manière d'exporter...ca m'arrangearit de ne pas refaire cette macro si possible ;)

Est ce que tu as une explication à ma situtation?toi ou un autre membre bien sûr!

Fab.

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #87012 by DenisChenu
DenisChenu replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
C'est l'export des stats excel et non des réponses.

Le rapport de bug, c'est pour les stats réponse :).

C'est pas la même chose.

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 5 years 1 month ago by DenisChenu.
The following user(s) said Thank You: FabienO

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #87016 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Oui je me suis un peu embrouillé avec les termes...je reprend
c'est au moment de l'export des stats excel que mon erreur apparaît avec firefox, sous chrome il me met erreur 6 et sous explorer erreur 500.
Mais lors de l'export des réponses tout fonctionne.

Par contre, en local tout fonctionne bien pour l'export des stats excel mais lorsque j'ouvre le fichier il y a un message erreur suivant :



Et si je clique sur le fichier s'ouvre mais est complétement vide. Ceci rejoint la description du bug que j'ai lu.

Je voudrais principalement découvrir pourquoi l'export des stats excel ne fonctionne pas sur le serveur svp...En ce concerne le bug du rapport je serai être patient ;)
Last Edit: 5 years 1 month ago by FabienO.

Please Log in to join the conversation.

More
5 years 1 month ago #87027 by Ben_V
Ben_V replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Là je sêche complètement :( ....

Le seul truc que je verrai là peine d'essayer c'est la même manip avec tout en anglais (un petit questionnaire EN + se loguer en anglais au niveau de l'interface)
Je dis celà car j'avais eu il y a longtemps un problême avec excel qui me sortait un message d'erreur à l'ouverture genre fichier corrompu just dû au fait qu'il commençait par je ne sais plus qu'elle voyelle accentuée....

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: FabienO

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #87043 by DenisChenu
DenisChenu replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Salut,

J'ai le même bug sur l'export des stats (erreur 404). Je jette un oeil ce matin.

PS: rapport de bug : bugs.limesurvey.org/view.php?id=6730

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 5 years 1 month ago by DenisChenu. Reason: PS
The following user(s) said Thank You: FabienO

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #87047 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Salut Ben,

Je pensais que le message d'erreur que j'avais à l'ouverture du fichier excel correspondait à celui évoqué dans le rapport de bug que tu m'as transmis. En tout cas, cela y ressemble beaucoup pour moi mais du coup j'en suis moins sûr ;)

Salut Denis,

Je vais suivre le rapport de bug et si tu as trouvé la solution n'hésites pas à me faire signe ;)
Last Edit: 5 years 1 month ago by FabienO.

Please Log in to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #87498 by FabienO
FabienO replied the topic: Problème lors de l'exportation des réponses sous excel apparu avec la version 2
Salut Denis et Benitov,

Je viens d'installer la mise à jour comprenant le correctif pour le bug que Denis m'avait communiqué. Tout fonctionne bien maintenant!!!

Merci à vous pour votre aide!
Bonne journée.
Last Edit: 5 years 2 weeks ago by FabienO.
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!