Bug détecté après MAJ 1.92+

More
4 years 10 months ago #84396 by Philippe
Philippe created the topic: Bug détecté après MAJ 1.92+
Bonjour à tous et particulièrement aux gurus.

Je pense que je me trompe d'endroit pour déclarer un bug que je viens de constater mais j'ai pas d'idée où mettre ça ailleurs...
--
- J'ai effectué une MAJ de la 1.91 vers la 1.92+ hier
- ça fonctionne correctement en apparence sauf qu'a l'examen des résultats j'ai un bug étrange :
- Pour tous mes questionnaires activés antérieurement à la MAJ, pour une nouvelle saisie à partir d'hier (MAJ) la date de dernière action et la date lancement (si elle était pas renseignée) se retrouve à 1980-01-01 00:00:00
- Par contre pour le questionnaire que j'ai activé hier après la MAJ ça fonctionne correctement et enregistre bien le bon horodatage...

Étrange n'est ce pas ?

Philippe

Please Log in to join the conversation.

More
4 years 10 months ago #84407 by DenisChenu
DenisChenu replied the topic: Bug détecté après MAJ 1.92+
Salut,

C'est pour des questionnaires terminé ?

On ne fait peut être plus les bon test pour mettre Y à terminé, je sais pas trop. Quand tu dis non renseigné : ce sont des questionnaires anonyme, c'est ça ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 10 months ago #84409 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Bonjour Denis,

Non, ce sont des questionnaires toujours en activité, ouverts avant que je fasse la MAJ (hier) vers la 1.92+.
J'ai constaté le bug cette nuit quand un des questionnaires (qui est en activité depuis plus d'un an) a été rempli. J'ai vu cette date bizarre... Du coup j'ai fais des test et ça fait ça sur tous les questionnaires activés antérieurement à la MAJ 1.92+ (hier)
Par contre, le questionnaire que j'ai activé hier soir APRES la MAJ lui ne comporte pas ce bug, le champs se rempli de la bonne date.
---
Quand je dis non renseigné c'est à propos du 2ème champs de date ("date de lancement" dudit questionnaire) y en avait que je n'avais pas défini initialement et j'ai remarqué que dans ce champs ça mettait la même date que dans le champs "dernière action" (celui qui merdouille maintenant)...
---
Je vais regarder pour le "Y" de terminer mais il me semble (de mémoire) que le questionnaire de cette nuit était terminé = Y...

So bizarre...
Philippe

Please Log in to join the conversation.

More
4 years 10 months ago #84413 by DenisChenu
DenisChenu replied the topic: Bug détecté après MAJ 1.92+
Salut,

Il me semble que les champs "date de lancement" et dernière action sont sur des types date.

Les champs SQL de type date ont obligatoirement une date, je ne sais plus trop comment c'était avant.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 10 months ago #84418 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Re,

Effectivement il semble que ça toujours été des champs de type "date"...
Même maintenant, et je pense que c'est juste que c'est pas (plus) nourri et c'est pourquoi ça affiche maintenant 1980-01-01 00:00:00... Ce doit être la valeur minimale par défaut de ce type de champs...

Philippe

Please Log in to join the conversation.

More
4 years 10 months ago #84427 by DenisChenu
DenisChenu replied the topic: Bug détecté après MAJ 1.92+
Salut,

La valeur minimum dépend du serveur, donc les dev ont décidé de la passer à 1980-01-01 00:00:00.

Par contre, on ne devrait pas l'afficher, cela devait être le cas sur la 1.91.

Tu peux remonter le bug ? Pas urgent mais à prévoir.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 10 months ago #84429 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Heu, juste par ce que c'est ma "première fois"
Comment je fais pour "remonter le bug" ? Y a une petite clé dans le dos ? B)
C'est dans la page d'accueil du forum ? en anglais ?
Philippe

Please Log in to join the conversation.

More
4 years 10 months ago #84436 by DenisChenu
DenisChenu replied the topic: Bug détecté après MAJ 1.92+
Salut,

Tu peux te connecter avec le même compte que celui du forum.
www.limesurvey.org/fr/communaute/suivi-de-bugs

Par contre, c'est vrai qu'il faut rapporter en anglais.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 10 months ago #84464 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Bonjour,
Bon, c'est fait. Du coup j'ai un peut cherché sur le forum des bug car il semble qu'il y en ait un identique dans la RC de la 2.0 dont le fil parlait de format de date (yyyy/mm/dd versus le notre)
J'ai un peu testé différent format proposé mais le problème reste identique.
Donc j'ai rapporté...
A Bientôt
Philippe

Please Log in to join the conversation.

More
4 years 5 months ago #90698 by lemontree
lemontree replied the topic: Bug détecté après MAJ 1.92+
Bonjour,

Je viens de tomber sur le même cas de figure que toi, en réactivant un questionnaire et entre temps j'avais dû changer de version, je suis désormais en Version 1.92+ Build 120919

Avais-tu trouvé une solution ?

Please Log in to join the conversation.

More
4 years 5 months ago #90775 by DenisChenu
DenisChenu replied the topic: Bug détecté après MAJ 1.92+
Salut,

Attention, peut être un changement dans l'enregistrement des dates: tenté avec:
- Réponses datées ? à OUI

Sinon, testez avec: - Questionnaire non anonyme

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 years 5 months ago #90817 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Bonjour,
Je m'excuse de répondre un peu tardivement mais je rentre de congés...
A l'époque j'avais "remonté" ce problème dans le bugtraker mais la réponse était que ce n'était pas un bug mais un choix des développeurs en matière de sécurité (sic)
Si on passe le questionnaire en non anonyme alors on a la bonne date qui s'afficherait...

J'avoue que j'ai pas cherché trop ...
Le problème c'est qu'à ce jour j'arrive plus à retrouver le fil du post sur le trakker...
-
Sinon j'ai résolu de manière assez peu élégante certe... en ajoutant un champs date dans mes questionnaires...

Voilà...
Pas très aidant comme réponse... Désolé

Philippe
The following user(s) said Thank You: lemontree

Please Log in to join the conversation.

More
4 years 5 months ago #90850 by lemontree
lemontree replied the topic: Bug détecté après MAJ 1.92+
Bonjour,

Merci de vos retours, j'aurai bien tenté de passer les paramètres Réponses datés à Oui et questionnaire non anonyme, mais malheureusement j'ai des réponses dans ce questionnaire et sauf erreur de ma part je ne peux pas l'arrêter pour changer ces paramètres car du coup me réponses ne seront plus accessibles par LS.

Please Log in to join the conversation.

More
4 years 5 months ago #90875 by Philippe
Philippe replied the topic: Bug détecté après MAJ 1.92+
Bonjour,
Alors bonne nouvelle ...
Je viens d'aller vérifier sur un de mes questionnaires (activé depuis janvier 2011) qui est en mode anonyme et sur lequel j'avais constaté ce problème de fausse date de lancement et dernière action...
--
Et bien depuis que je suis passé à la V2 de LS le remplissage de ces champs de date est redevenu correct.
--
Je vois très bien dans mon listing de résultat le "gap" entre le 08/08/2012 date ou je suis passé en 1.92+ et le 20/12/2012 date ou je suis passé en V2... et ou ça refonctionne...

Donc...
faut probablement envisager l'upgrade vers la V2.

A titre personnel je n'ai migré qu'un seul de mes 3 serveurs. Juste car je n'ai pas encore eu le temps de faire les deux autres... C'est prévu...
J'ai eu un problème de "page blanche" au demarrage de l'install automatique, j'ai réglé ça en copiant manuellement mon ancien config.php qui n'avait pas été recopié...
Sinon, a ce jour je n'ai pas de "bug" important a signaler.


Espérant avoir aidé
Bien cordialement

Philippe

PS : On pourrait probablement passer ce fil à "réglé" non ?

Please Log in to join the conversation.

More
4 years 5 months ago #90993 by lemontree
lemontree replied the topic: Bug détecté après MAJ 1.92+
Merci Philippe et Denis pour vos retours,

Bien noté Philippe dans ton dernier message que la solution semblait passer par un passage vers la V2.

J'hésite encore à le faire, mais tes propos rassurant sur la stabilité de la v2 vont peut-être me convaincre d'y aller.

A suivre

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now