Passage d'une réponse dans paramètre de l'URL

More
4 years 10 months ago #79993 by rodparis
Bonjour à tous,
Est-il possible de passer la réponse à une question directement dans l'URL d'appel au questionnaire.
Pour exemple, je souhaite poser une question de type numérique. Afin d'éviter que la personne saisisse cette valeur, je souhaitais savoir s'il était possible de passer cette valeur dans l'URL afin que le champ se préremplisse et, en bonnus, qu'il passe automatiquement à la question suivante ?

J'espère avoir été clair.

Merci à tous

Please Log in to join the conversation.

More
4 years 10 months ago #80007 by Nickko
Il faudrait être plus précis.
Je pense que ce n'est possible que si tu n'as pas activé l'écran de bienvenue et que ta question est dans le premier groupe.

Toutefois, il serait plus simple de procéder autrement, mais pour te proposer un autrement, il faut que je connaisse ton problème.

Pourrais-tu nous expliquer ton problème et nous essaierons de trouver une solution. C'est souvent plus efficace que de chercher à implémenter une solution que tu as imaginé et qui n'est pas adaptée à LS.

Passer un paramètre dans l'URL est une solution, la réponse à un besoin, pas un besoin en lui même.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 10 months ago #80008 by DenisChenu
Salut,

Désolé Nickko de te contredire, c'est rare, mais il existe un solution faites pour ça exactement. C'est même la seulesoution pour remplir les questions cachées depuis la 1.90.

Prefilling survey answers using the survey URL

C'est super mal rangé dans la doc , mais c'est là :).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: rodparis

Please Log in to join the conversation.

More
4 years 10 months ago #80015 by rodparis
Merci,

En fait j'avais posté un peu dans la hâte et j'ai réussi a trouver entre temps dans les Workaround.
En somme, il y a un bug dans la nouvelle version et afin de rendre opérationnel le passage des paramètres dans l'URL, il faut aussi passer le param newtest=y.
Mon problème venait du fait que je passais les paramètres mais rien de s'affichait jusqu'au moment où j'ai découvert le contournement.
Néanmoins, est-ce que quelqu'un sait si le bug va être résolu ?

Cdt

Please Log in to join the conversation.

More
4 years 10 months ago #80016 by DenisChenu
Il faut le rapporter : bugs.limesurvey.org ;)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 5 months ago #86632 by rodparis
pas eu encore le temps de le faire ... c'est corrigé ?

Please Log in to join the conversation.

More
4 years 5 months ago #86648 by DenisChenu

rodparis wrote: pas eu encore le temps de le faire ... c'est corrigé ?

Heu, je sais pas il faut tester :)

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Moderators: Nickko