Problem installation sous OVH

More
5 years 6 months ago #79874 by RiposteVerte
RiposteVerte created the topic: Problem installation sous OVH
Bonsoir,

J'essaie sans succès d'installer Limesurvey sur un serveur mutualisé OVH.

Le site est développé sous Worldpress.
J'ai modifié le fichier config avec

$databaselocation = 'mysql51-32.pro';
$databasename = 'nom de la base';
$databasepass = 'mot de passe';
$dbprefix = 'lime_';

Je me suis demandé si mon problème venait de l'emplacement du site qui sur le serveur st dans un dossier nommé wp (donc dans www/wp/)
J'ai bien mis le dossier Limesurvey dans ce dossier wp et j'ai changé
$rooturl = "http://{$_SERVER}/limesurvey";
par
$rooturl = " www.apc-carbone.fr/limesurvey ";
et même
$rooturl = " www.apc-carbone.fr/wp/limesurvey ";

sans plus de succès. A chaque fois, la page n'est pas trouvée.

J'ai essayé en mettant le dossier limesurvey au même niveau que le wp
Ca ne marche pas plus

Quelqu'un aurait il une idée

Merci d'avanc

Valery

Please Log in to join the conversation.

More
5 years 6 months ago #79876 by holch
holch replied the topic: Problem installation sous OVH
Sorry, my french is really bad. If I got you right your problem is that you are deleting "http://{$_SERVER}"

You should leave this there, because in most cases Limesurvey finds it way.

Try this:
$rooturl = "http://{$_SERVER['HTTP_HOST']}/wp/limesurvey";

This should direct LS to www.apc-carbone.fr/wp/limesurvey

If this is where you have put your LS files, you should be fine.

The "www.apc-..." versions will never work. http:// is missing.

Hope that helps.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #79877 by holch
holch replied the topic: Problem installation sous OVH
Just checked your site and the code above should definitely work, because your LS files are in the folder wp/limesurvey/

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last Edit: 5 years 6 months ago by holch.

Please Log in to join the conversation.

More
5 years 6 months ago #79890 by RiposteVerte
RiposteVerte replied the topic: Problem installation sous OVH
J'ai mis (I wrote)
$rooturl = " www.apc-carbone.fr/wp/limesurvey ";

puis je mets l'url suivante (then I ask this url) :
www.apc-carbone.fr/wp/limesurvey/admin/install/

et voilà le message :

Warning: require_once(/homez.383/apccarbo/www/wp/limesurvey/admin/install/../update/updater.php) [function.require-once]: failed to open stream: No such file or directory in /homez.383/apccarbo/www/wp/limesurvey/admin/install/index.php on line 22

Fatal error: require_once() [function.require]: Failed opening required '/homez.383/apccarbo/www/wp/limesurvey/admin/install/../update/updater.php' (include_path='.:/usr/local/lib/php') in /homez.383/apccarbo/www/wp/limesurvey/admin/install/index.php on line 22

si je tape (If I ask this url) :
www.apc-carbone.fr/limesurvey/admin/install/
Alors la page n'est pas trouvé (error 404)

Mrci pour vos remarques

Valery

Please Log in to join the conversation.

More
5 years 6 months ago #79892 by holch
holch replied the topic: Problem installation sous OVH
You need the http:// part, without it, it will never work.

However, if you use the code that I have shown you, LS usually finds the right path themselves. Have you tried the code I have posted? Exactly as it is? Not include your domain, but only the path after the domain?

Copy exactly this:
$rooturl = "http://{$_SERVER['HTTP_HOST']}/wp/limesurvey";

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 6 months ago #79898 by DenisChenu
DenisChenu replied the topic: Problem installation sous OVH
Salut,

Ton nom d'utilisateur ovh est bien apccarbo ?

Dans le répertoire ftp, tu as quoi exactement ?

www/wp/limesurvey ?
Tu as bien un répertoire www/wp/limesurvey/update/ et un fichier updater.php ?

Tu as forcé le PHP5 dans le htaccess de OVH ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
5 years 6 months ago #79906 by RiposteVerte
RiposteVerte replied the topic: Problem installation sous OVH
Bonjour Denis,

Mon nom OVH est bien apccarbo mais pour rentrer sur la base c'est apccarbobase1

J'ai bien www/wp/limesurvey
par contre je n'ai pas drépertoire www/wp/limesurvey/update/ ni de fichier updater.php ?

Je n'ai pas forcé le PHP5 dans le htaccess de OVH du moins moins. Est ce que l'agence qui a développé l site sous worldpress l'a fait, je ne pense pas.

Merci d'avance

Valery

Please Log in to join the conversation.

More
5 years 6 months ago #79907 by DenisChenu
DenisChenu replied the topic: Problem installation sous OVH

RiposteVerte wrote: par contre je n'ai pas drépertoire www/wp/limesurvey/update/ ni de fichier updater.php ?

Comment as tu installé LS ?

Il te manque des fichiers, télécharge de nouveau les fichiers et refait le transfert des fichiers.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
5 years 6 months ago #79913 by RiposteVerte
RiposteVerte replied the topic: Problem installation sous OVH
Denis,

Après avoir réinstallé le répertoire limesurvey sur l serveur, cela a marché.

Merci pour ton aide

Valery

Please Log in to join the conversation.

More
5 years 6 months ago #80619 by deazure
deazure replied the topic: Problem installation sous OVH
Bonjour a toute la communaute .
j'ai installer le cms chez mon hebergeur avec les parametres :

$databaselocation = 'localhost';
$databasetype = 'mysql';
$databaseport = 'default';
$databasename = 'nom de ma base';
$databaseuser = 'nom de connexion';
$databasepass = '******';
$dbprefix = 'lime_';
$databasetabletype = 'myISAM';

QUAND JE LANCE MA page j'obtient ca :
The requested URL /limesurvey/admin/install/index.php was not found on this server.
Apache/2.2.3 (CentOS) Server at limesurvey.atmcom-regie.com Port 80

quelqun peut il m'aider je compte sur vous merci

Please Log in to join the conversation.

More
5 years 6 months ago #80621 by adamskpe
adamskpe replied the topic: Problem installation sous OVH
Bonsoir,

J'ai eu le même problème il y a quelques semaines et j'ai pris mon courage à deux mains ce week-end pour le résoudre.

je pense qu'il y a un problème de chemin d'accès au fichier lorsque ...

De plus ne toucher pas au $rooturl = "http://{$_SERVER}.

Je vous conseillerai plutôt de mettre le contenu de LimeSurvey directement dans le reperoire WP et de supprimer le "/limesurvey pour obtenir

$rooturl = "http://{$_SERVER} .

C'est exactement ce que j'ai fait et çà a marché.

Bon courge !

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!