Check out the LimeSurvey source code on GitHub!

Bug ?

More
5 years 2 months ago #70992 by pitou31
Bonjour,
Je pense qu'il y a un bug dans la fonction Statistiques rapides.
Tout fonctionne bien jusqu'au moment ou on demande de filtrer sur un champ (prénom par exemple). L'affichage fonctionne et c'est bien filtré on ne reçoit que les réponses correspondant au filtre sur le prénom (par exemple une seule réponse sur "Michel".
Ensuite quelle que soit la recherche avec ou sans filtre la génération SQL est erronée et donne le message d'erreur suivant :

Couldn't get results
SELECT count(*) FROM `lime_survey_62392` WHERE 627X2X2SQ002` LIKE 'Michel')
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '` LIKE 'Michel')' at line 1

Merci de me dire si vous avez eu le même problème et s'il s'agit bien d'un bug.

Please Log in to join the conversation.

More
5 years 2 months ago #71011 by DenisChenu
Salut,

Pour poste un rapport de bug, vérifie dabord que tu es sur la dernière version ( Version 1.91+ Build 11379 ) ?

Perso j'ai vérifié sur mon installation, pas de soucis. Cependant uil est possible que : selon le questionnaire, selon le serveur, selon les résultats; cela soit différent.

Si tu es sur la Version 1.91+ Build 11379, sans modification : gogogo !

Please test if the problem still exists at the latest release . If so please open a ticket at the Bugtracker and...

  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the Bugtracker so we can follow the progress.


Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #71032 by pitou31
Bonjour,
Merci pour votre réponse.
J'ai bien la version Version 1.91+ Build 11379.
Je ne pense pas avoir un questionnaire qui sorte de l'ordinaire (juste des questions classiques de format texte, des réponses par oui et non, choix multiple, ou bouton radio.
Je suis sur le serveur WAMP local, y aurait-il un problème avec PHP Admin et Mysql ? Possible puisque vous semblez confirmer que l'usage des filtres ne posent pas de problème.
Il faudrait sans doute que je teste la même chose sur un serveur en ligne mais ça ne m'est pas possible actuellement. Curieux tout de même de voir que la première fois qu'on emploie un filtre ça fonctionne et plus pour les fois suivantes, et de voir que la génération des instructions SQL semble erronée.
Je suis pour l'instant bloqué en attendant de faire un test sur un autre serveur.
Je peux également envoyer mon formulaire à titre privé pour le faire vérifier sur une autre <a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '>installation</a> (comment faire ?).
Merci.
Last Edit: 5 years 2 months ago by pitou31.

Please Log in to join the conversation.

More
5 years 2 months ago #71053 by DenisChenu
Salut,

Non, non, si ca ne marche pas sur ton installation , go go go !

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 2 months ago #71058 by pitou31
Que veux-tu dire ? Mon installation ne semble pas poser de problème, ni même les premières exploitations y compris le premier test avec le filtre sur le champ prénom par exemple. Ce n'est qu'après que le problème se pose.
Que conseilles-tu ?

Please Log in to join the conversation.

More
5 years 2 months ago #71066 by DenisChenu

pitou31 wrote: Que veux-tu dire ?

De faire le rapport de bug détaillé si possible.

Il est possible que ton problème surviennent pour d'autres personnes. :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: pitou31

Please Log in to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #71072 by pitou31
C'est fait à Bugtracker

[edite/shnoulle] bug link : bugs.limesurvey.org/view.php?id=5628
Last Edit: 5 years 2 months ago by DenisChenu. Reason: bug link

Please Log in to join the conversation.

More
5 years 2 months ago #71078 by DenisChenu
Merci :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #71245 by pitou31
Pour info:
J'ai reproduit le même problème sur un serveur distant.
Il ne s'agit donc pas d'un problème lié à une <a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '><a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '><a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '><a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '><a href=' www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey '>installation</a></a></a></a></a> locale.
Je vous joints le fichier questionnaire si vous souhaitez essayer de reproduire ce que j'ai expliqué.

File Attachment:

File Name: limesurvey...1627.lss
File Size:63 KB


Méthode de test:
1. Répondre au questionnaire,
2. Aller à "Réponses & Statistiques",
3. Lancer la fonction "Donner les statistiques de ces réponses" et cliquer sur "Afficher les statistiques".
Ça doit fonctionner sans problème.
4. Utiliser un filtre (n'importe lequel correspondant à une de vos réponses)
et demander d'"afficher les statistiques".
Ça doit fonctionner sans problème.
5. Effacer les filtres utilisés et redemander les statistiques sans filtre.
En principe le problème arrive à ce stade avec un message d'erreur SQL.
Merci à tous si vous pouviez me confirmer ou m'infirmer le problème.
Attachments:
Last Edit: 5 years 1 month ago by pitou31.

Please Log in to join the conversation.

More
5 years 1 month ago #71318 by DenisChenu

pitou31 wrote: 5. Effacer les filtres utilisés et redemander les statistiques sans filtre.
En principe le problème arrive à ce stade avec un message d'erreur SQL.
Merci à tous si vous pouviez me confirmer ou m'infirmer le problème.

Je confirme,

Cela pose problème.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: pitou31

Please Log in to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #72499 by pitou31
Bonne nouvelle.
Le bug semble être résolu. :lol: A tester.
bugs.limesurvey.org/view.php?id=5628
Last Edit: 5 years 1 month ago by pitou31.

Please Log in to join the conversation.

More
5 years 1 month ago #72502 by pitou31
Après avoir testé le bug est toujours là.:( Peut-être faut-il une mise à jour de la version ?

Please Log in to join the conversation.

More
5 years 1 month ago #72522 by DenisChenu
Salut,

Le bug est réglé pour la prochaine version mineure de LS, en général une fois par semaine quand il y a eu un bug résolu. Sans doute mercredi ou lundi prochain.

Sinon, tu peux prendre la version SVN : docs.limesurvey.org/Accessing+the+source...meSurvey+development

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: pitou31

Please Log in to join the conversation.

More
5 years 4 weeks ago #72821 by pitou31
Salut,
Je viens de procéder à la mise à jour de la nouvelle release et au test.
C'est bien corrigé et ça fonctionne.
Content d'avoir pu participer à l'amélioration de ce très bon produit.:)
Je vais essayer de le mettre en production auprès de professeurs dans le cadre d'un essai d'outil pédagogique.
A+

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form