Check out the LimeSurvey source code on GitHub!

impossible de me connecter en admin aprés installation

More
5 years 6 months ago - 5 years 6 months ago #64975 by lobotomys
bonjour, voila, j'ai installé limesurvey ici : survey.hearingtrauma.com

j'ai un peu tout essayé, j'ai mis la ligne $sessionhandler = 'db'; dans mon config.php, j'ai un .htaccess avec rien d'autre que : <IfModule mod_php5.c>
php_value session.auto_start 0
</IfModule>

le probleme persiste, en rentrant le admin password comme login sur la page d'admin, je reviens sur la page en boucle ! help !! merci.
Last Edit: 5 years 6 months ago by lobotomys.

Please Log in to join the conversation.

More
5 years 6 months ago #64976 by Nickko
As-tu cherché un peu sur ce forum ?
La question du retour en boucle sur la page d'accueil a déjà été abordé, mais je ne sais plus quelle était la solution.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 6 months ago #64977 by lobotomys
oui, j'ai passé une bonne partie de la matiné a chercher et essayer des solutions proposés sans succés.

Please Log in to join the conversation.

More
5 years 6 months ago #64980 by Nickko
Qu'as-tu déjà essayé ?

Nickko
Ergonome / Usability expert
The following user(s) said Thank You: lobotomys

Please Log in to join the conversation.

More
5 years 6 months ago #64981 by lobotomys
ce que j'ai indiqué si dessus dans mon premier message.

modification du config.php et le .htaccess , dans le htaccess, y avait d'autre ligne (rewriting), j'ai essayé avec et sans, ça n'a rien changé. je n'ai pas accés au php.ini chez mon hebergeur. je suis chez dreamhost.com

Please Log in to join the conversation.

More
5 years 6 months ago #64982 by Nickko
Ok, alors tu n'as pas essayé grand chose ;-)

La première des idées qui me vient c'est de refaire l'installation depuis une v1.91 toute neuve.

Ensuite de vérifier tes cookies.

Tu peux aussi me donner des identifiants pour que j'essaie de me connecter à ton serveur et voir si ça boucle de chez moi ou pas. Je n'ai besoin d'aucun droit particulier.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 6 months ago #64983 by lobotomys
j'ai déja refait 4 fois l'installation :) hihi ...

bon, je veux bien recommancer. je vais vider la base de données.
les pass et admin de survey.hearingtrauma.com sont admin et password.

si tu peux verifier dabord avant que je reinstalle tout, merci beaucoup !!

voici ce qu'il y a dans le config.php et le .htaccess

$sessionhandler = 'db';
$databasetype = 'mysql'; // ADOdb database driver - valid values are mysql, mysqli, odbc_mssql, mssql_n, odbtp or postgres
// mysql: Recommended driver for mysql
// mysqli: Slightly faster driver for mysql - not on all server systems available
// odbc_mssql: MSSQL driver using ODBC with MS SQL Server
// mssqlnative: Native SQL Server driver for SQL Server 2005+
// mssql_n: Experimental driver for MS SQL Server which handles UTF-8 charsets
// odbtp: ODBTP driver to access MSSQL-Server is needed for this one - we also recommend to activate $databasepersistent for decent speed
// postgres: Standard postgres driver

$databaselocation = 'mysql.survey.hearingtrauma.com'; // Network location of your Database - for odbc_mssql or mssqlnative use the mssql servername, not localhost or IP
$databasename = 'survey_hearingtrauma_com'; // The name of the database that we will create
$databaseuser = 'didiermartinicom'; // The name of a user with rights to create db (or if db already exists, then rights within that db)
$databasepass = 'KqP26Rt.'; // Password of db user
$dbprefix = 'survey_'; // A global prefix that can be added to all LimeSurvey tables. Use this if you are sharing
// a database with other applications. Suggested prefix is 'lime_'

// File Locations
$rooturl = " survey.hearingtrauma.com "; // The root web url for your limesurvey installation (without a trailing slash).
// The double quotes (") are important.

$rootdir = dirname(__FILE__); // This is the physical disk location for your limesurvey installation. Normally you don't have to touch this
// setting. If you use IIS then you MUST enter the complete rootdir e.g. : $rootDir='C:\Inetpub\wwwroot\limesurvey'!
// Some IIS and OS/2 installations also require to use forward slashes
// instead of backslashes, e.g. $rootDir='C:/Inetpub/wwwroot/limesurvey'!

//installation Setup
$defaultuser = 'admin'; // This is the username when LimeSurvey is installed and the administration user is created on installation
$defaultpass = 'password'; // This is the password for the administration user when LimeSurvey is installed

// Debug Settings
$debug = 1; // S

.htaccess :

<IfModule mod_php5.c>
php_value session.auto_start 0
</IfModule>

c'etait au départ un htaccess.txt que j'ai renommé en .htaccess (dans les deux cas, ça ne marchait pas)

Please Log in to join the conversation.

More
5 years 6 months ago #64984 by lobotomys
je remarque dans rootURL, j'ai pas mis de // ou de http:// , ça viendrait de la ?

Please Log in to join the conversation.

More
5 years 6 months ago #64985 by Nickko
Quand je te demandais ce que tu avais essayé, c'était pour ne pas te reproposer les mêmes choses :-p

pour le rootURL : ça peut, le mieux c'est de tester.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 6 months ago #64986 by lobotomys
ok, je vais essayer :). merci de ton aide !

Please Log in to join the conversation.

More
5 years 6 months ago #64987 by lobotomys
ahah, en fait, si c'etait deja fait, c'est le forum qui a remplacé le http par un lien direct ... bon

a part refaire une installation toute propre (mais deja fait 4 fois)... y a t il des choses que j'aurais pu oublier ?

Please Log in to join the conversation.

More
5 years 6 months ago #64988 by Nickko
Dans tous les cas, dis nous ce qu'il ne est (comme c'est un pb qui revient souvent, un nouveau cas de figure traité est toujours une bonne chose).

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 6 months ago #64989 by lobotomys
ok, je vais tout reinstaller, et je vous tiens au courant de la procedure ici.merci

Please Log in to join the conversation.

More
5 years 6 months ago #64990 by lobotomys
voila, j'ai tout reinstallé. meme probleme.
il y a le htaccess.txt, dois je le renommer en .htaccess ? que dois je y mettre dedans ? actuellement, il y a ça :

## MOD_REWRITE for LimeSurvey ##
<IfModule mod_rewrite.c>
RewriteEngine On

## DONT TOUCH ANYTHING ##
# Only with survey code
# server.fr/123456
RewriteRule ^([0-9]+)/*$ index.php?sid=$1 [L,QSA]

# Survey code + Lang : server.fr/123456/lang-fr
RewriteRule ^([0-9]+)/lang-([^/]*)/*$ index.php?sid=$1&lang=$2 [L,QSA]

# Survey code + Lang + Token : server.fr/123456/lang-fr/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/lang-([^/]*)/tk-([^/]*)/*$ index.php?sid=$1&lang=$2&token=$3 [L,QSA]

# Survey code + Token : server.fr/123456/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/tk-([^/]*)/*$ index.php?sid=$1&token=$2 [L,QSA]
</IfModule>

tous les repertoires sont en 755 chmod. dois je les passer en 777 ?

Please Log in to join the conversation.

More
5 years 6 months ago #64991 by Nickko
Non, je ne pense pas.

Ce que je te propose c'est de me créer un compte avec des droit limité et de me communiquer en privé les identifiants. Ainsi je pourrais tester et dire si ça vient de l'installation (version, serveur ou je ne sais quoi) ou de chez toi (navigateur, firewall ou autre).

Nickko
Ergonome / Usability expert
The following user(s) said Thank You: lobotomys

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form