Check out the LimeSurvey source code on GitHub!

Créer un nouveau modèle.

More
5 years 6 months ago - 5 years 6 months ago #64099 by hertay
Bonsoir,

En trois ans de bons et loyaux services rendus par LS, j'ai toujours adapté un des excellents modèles livrés avec l'outil et disponibles dans /templates/

Mais voilà ! Empêtré dans les chmod, j'ai toujours réglé le problème à la hussarde soit en modifiant un modèle original, soit en recopiant dans son propre répertoire un modèle original préalablement renommé.

Je pourrais continuer encore comme ça mais ça m'agace un peu ...
Je voudrais quand même arriver à utiliser correctement l'éditeur de modèles :
Ceci est un modèle standard. Si vous voulez le modifier, veuillez en faire d'abord une copie.


LS crée bien le nouveau répertoire monmodele dans /upload/templates/monmodele/ mais il est en 755 irrémédiablement ce qui bloque la recopie.Le safe_mode est à On. C'est là le problème ?

Merci et bonne soirée ;)

PS : ben oui ... Curieux que la documentation n'en fasse pas état formellement ?
Attachments:
Last Edit: 5 years 6 months ago by hertay.

Please Log in to join the conversation.

More
5 years 6 months ago #64127 by DenisChenu
Salut,

J'ai un peux le même soucis mais n'ai pas pris le temps.

Sur la plupart de mes serveurs cela fonctionne sans soucis, par contre sur un serveur en OVH release2, le répertoire créé n'est pas exécutable. J'avais regardé le code de LS, celui-ci n'impose aucune restriction, c'est donc le serveur qui ne créée pas les répertoire avec les bons droits.

A voir si le umask est bon : fr.wikipedia.org/Umask

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 6 months ago #64138 by hertay
Bonjour Shnoulle,

Shnoulle wrote: Salut,
J'ai un peux le même soucis mais n'ai pas pris le temps.

C'est souvent une question de temps ... ;)

Sur la plupart de mes serveurs cela fonctionne sans soucis, par contre sur un serveur en OVH release2, le répertoire créé n'est pas exécutable. J'avais regardé le code de LS, celui-ci n'impose aucune restriction, c'est donc le serveur qui ne créée pas les répertoire avec les bons droits.
A voir si le umask est bon : fr.wikipedia.org/Umask

Je ne mets jamais chez OVH un outil qui a la possibilité d'envoyer du courrier en masse car sa mise en oeuvre est souvent un problème.

Cela dit, je confirme que le safe_mode doit être à Off ; à partir de là, l'éditeur de modèles (LS Version 1.91+ Build 10604) fonctionne parfaitement à savoir
  • la copie d'un modèle existant et sa destruction,
  • la modification et la sauvegarde des templates.
alors que par ftp, c'est impossible.

En mode dégradé, il est toujours possible de créer par ftp le sous-répertoire /monmodèle/ et d'y copier/coller le modèle livré. Avec les bons droits. L'éditeur de modèles s'en accommode parfaitement.

En revanche, je ne sais pas si en procédant en mode dégradé, on perd quelque chose que l'éditeur de modèles fait en plus ou en complément. Je ne vois pas ...

Merci ;)

Please Log in to join the conversation.

More
5 years 6 months ago #64144 by DenisChenu
Salut,

Je travail plus souvent en ftp pour les modèle/template .

Sinon, comme cela dépend du serveur, je ne vois pas trop .

A propos : je vient de régler le probleme sur un dédié OVH, configuration de suphp ;)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 6 months ago #64153 by hertay
Bonjour Shnoulle,

Shnoulle wrote: Salut,
Je travail plus souvent en ftp pour les modèle/template .

Oui, mais puisque l'éditeur de modèles permet la copie, etc., j'aime autant m'en servir ;)

Sinon, comme cela dépend du serveur, je ne vois pas trop .

Hm ! Ma question était de savoir si l'éditeur de modèles se contentait d'injecter une copie du template original ou s'il réalisait une tâche complémentaire, tel que renseigner un champ par ex. Ca n'a pas l'air d'être le cas. Il faudrait lire les scripts pour en être certain.

A propos : je vient de régler le probleme sur un dédié OVH, configuration de suphp ;)

Oui ? Mais encore ? :)

Please Log in to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #64162 by DenisChenu

hertay wrote: Hm ! Ma question était de savoir si l'éditeur de modèles se contentait d'injecter une copie du template original ou s'il réalisait une tâche complémentaire, tel que renseigner un champ par ex. Ca n'a pas l'air d'être le cas. Il faudrait lire les scripts pour en être certain.

L'éditeur de modèle ne fait qu'une copie brute du répertoire dans upload/template.

Pour l'instant pas de modif de BDD.

:)

PS: Pour OVH, c'est un serveur dédié. suphp avec le masque 0033, passé en 0022.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
Last Edit: 5 years 6 months ago by DenisChenu.

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form