Check out the LimeSurvey source code on GitHub!

Insertion image

More
5 years 11 months ago #58547 by Nat82
Bonjour,
Je n'arrive pas à insérer une image lors du message de bienvenue (1ère partie du questionnaire). Je fais insérer une image, parcourir. Voici le message : "The server didn't reply with a proper XML data. Please check your configuration."

J'ai placé l'image sur le serveur, dans le dossier upload/images.
Je ne comprends pas.
Merci pour votre aide.

Please Log in to join the conversation.

More
5 years 11 months ago #58555 by Nickko
J'ai déjà vu ce genre de message, mais c'était avec Dokuwiki, je pense que ce n'est pas limé à LS mais au module WYSIWYG.

Il n'y a qu'a faire une petite recherche sur internet pour s'en convaincre.

Sur le forum LS j'ai trouvé ceci qui pourrait t'aider : www.limesurvey.org/fr/forum/installation...th-a-proper-xml-data

Ça nous renvoie au Wiki : docs.limesurvey.org/tiki-index.php?page=...FCKEditor_won_t_load

Avec qq solutions :
FCKeditor can't be loaded and the following Error is displayed:
Error loading "limesurvey/admin/scripts/fckeditor/fckstyles.xml"

This is due a a web server misconfiguration. Try adding the following line to your httpd.conf file (for Apache), or to your .htaccess file in your LimeSurvey directory (if you're not the web server administrator):
AddType application/xml .xsl

Some have reported that given their Apache setup they had to use the following two lines instead:
RemoveHandler .xml
AddType application/xml .xml

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 11 months ago #58564 by Nat82
j'ai ajouté dans .htaccess de LimeSurvey, la ligne
AddType application/xml .xsl

voici maintenant qu'il ajoute bien l'image mais ne la reconnais pas.
je joins une capture d'écran. J'ai essayé avec d'autres formats que l'image en .gif. Pas de résultat.

Egalement, j'ai ajouté dans le fichier httpd.conf d'Apache
RemoveHandler .xml
AddType application/xml .xml

Pas de changement. Je continue à regarder les infos que tu m'as envoyé en lien.

PS : à quoi sert FCKeditor et où le trouve-t-on ?

Merci

Please Log in to join the conversation.

More
5 years 11 months ago #58565 by Nat82

File Attachment:

File Name: erreur_image.doc
File Size:42 KB


j'avais oublié le fichier.
Attachments:

Please Log in to join the conversation.

More
5 years 11 months ago #58567 by Nickko
FCK editor, c'est l'éditeur WYSIWYG utilisé par LS, tu le trouve dans les champs de textes ;-)

Pour ce qui est de ton fichier, s'il s'agit d'une image, je te conseille plutôt de l'enregistrer en PNG à l'aide de Paint par exemple.

Ainsi on peut la voir directement sans devoir télécharger un fichier Word.
Au bureau c'est bien plus pratique ;-)

Hormis les solutions que j'ai trouvé, je ne peux pas plus t'aider.
As-tu suivi les conversations sur le forum que j'ai trouvées ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 11 months ago #58569 by Nat82

Ainsi on peut la voir directement sans devoir télécharger un fichier Word.
Au bureau c'est bien plus pratique


Je ne comprends pas. Pourquoi tu parle de télécharger un fichier word ?

Pour le reste, oui je suis allée voir les liens et les posts à ce sujet. Je suis en cours pour tester les différentes solutions proposées.
J'avoue que c'est compliqué pour juste insérer une image !!
Mais je te tiens au courant et si je trouve (par miracle :huh: ) je mettrai la solution sur ce post.
Merci

Please Log in to join the conversation.

More
5 years 11 months ago #58571 by Nickko
"Je ne comprends pas. Pourquoi tu parle de télécharger un fichier word ?"

Ton fichier "erreur_image.doc" ce n'est pas une image tout de même, c'est bien un fichier Word.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 years 11 months ago #58573 by Nat82
ah ok. je mettrai une image direct la prochaine fois.
Pour revenir au problème d'image, j'ai trouvé ce forum .
A priori, cela viendra de FCKeditor.
Où ce trouve les fichiers de configuration de FCKeditor, notamment le config.php de cet éditeur ?

Please Log in to join the conversation.

More
5 years 11 months ago - 5 years 11 months ago #58574 by Nat82
forums.phplist.com/viewtopic.php?f=6&t=23394&start=30

Désolé, j'avais oublié le lien du forum.:huh:
Last Edit: 5 years 11 months ago by Nat82.

Please Log in to join the conversation.

More
5 years 11 months ago #58634 by Nat82
Solution trouvée :

dans : /admin/scripts/fckeditor.266/editor/filemanager/connectors/php
éditer le fichier config.php
puis modifier la ligne suivante à true (au lieu de false).

$Config = true ;

Ca marche, je peux insérer mon image.

Bonne journée

Please Log in to join the conversation.

More
5 years 11 months ago #58645 by Nickko
Merci pour ce retour d'expérience.

Je suis sur qu'il sera utile, sans doute même au delà de la communauté LS.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form