Check out the LimeSurvey source code on GitHub!

liens caduques dans les pages de sauvegarde et chargement d'un questionnaire

More
6 years 3 days ago - 6 years 3 days ago #57104 by rems

Nickko wrote: Tu as testé avec quels navigateurs ?

GoogleChrome et Firefox.

Nickko wrote: Essaie mon formulaire : je me suis p-ê trompé de lien ou je n'ai pas bien compris ta question : survey.usability.fr/index.php

Pas de problème pour ton questionnaire, les liens fonctionnent bien.

Je reviens sur ton observation "Et si $_SERVER ne renvoyait pas ce qu'il doit..." et me demande effectivement si il n'y a pas quelque part un problème de traitement de la variable ?!... Pourtant, via phpinfo j'ai bien l'url du site en face de _SERVER ...

Je suis un peu angoissé car le questionnaire est bientôt en ligne pour être soumis à la communauté nationale de l'enseignement agricole (commande du Ministère, et c'est moi qui est fait le choix de Limesurvey!) Il faut que résolve ce problème pour début mars...

Samuel REMOUE
DRTIC DRAAF Grand Est
Last Edit: 6 years 3 days ago by rems. Reason: Ajout

Please Log in to join the conversation.

More
6 years 3 days ago #57106 by Nickko
Essaie de le résintaller.

Utilises-tu la dernière version ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 years 3 days ago - 6 years 3 days ago #57113 by rems
C'est bien un problème d'appel de la variable.
J'ai résolu le problème en remplaçant, dans config.php, la variable _SERVER par l'adresse url du site "en dur" :
// File Locations
$rooturl            =   "http://...url...";

Je pense que c'est quelque chose à signaler et éclaircir, je ne dois pas être le seul à avoir rencontré ce problème... (Mais je ne suis pas à l'aise en anglais pour remonter cela au niveau de l'équipe de dev.).
Est-ce un problème au niveau du serveur ou de l'application ? Et comment en généraliser la résolution (pour tout le monde, autrement que par la modification personnalisée du fichier config.php) ?...

Samuel REMOUE
DRTIC DRAAF Grand Est
Last Edit: 6 years 3 days ago by rems.

Please Log in to join the conversation.

More
6 years 2 days ago #57128 by Nickko
Je pensais que tu l'avais fait en même temps que rootdir. D'où ma remarque sur le champ internet ^^

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 years 1 day ago #57187 by DenisChenu

rems wrote: Je pense que c'est quelque chose à signaler et éclaircir, je ne dois pas être le seul à avoir rencontré ce problème... (Mais je ne suis pas à l'aise en anglais pour remonter cela au niveau de l'équipe de dev.).

C'est un problème de serveur, cela veut dire que la variable n'es pas renseignée.

On peut éventuellement envisager de mettre un test si le cette variable est vide ou null mais ce ne sera que dans le config par défaut.

Voit tu une autre variable possible dans le phpconfig ? ET utilisable en remplacement.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 11 months ago #57271 by rems

Nickko wrote: Je pensais que tu l'avais fait en même temps que rootdir. D'où ma remarque sur le champ internet ^^

C'est souvent les choses les plus simples que l'on ne voit pas !!

Samuel REMOUE
DRTIC DRAAF Grand Est

Please Log in to join the conversation.

More
5 years 11 months ago #57274 by rems

Shnoulle wrote: C'est un problème de serveur, cela veut dire que la variable n'est pas renseignée. On peut éventuellement envisager de mettre un test si la cette variable est vide ou null mais ce ne sera que dans le config par défaut. Vois-tu une autre variable possible dans le phpconfig ? ET utilisable en remplacement.

Je ne suis pas assez compétent en la matière pour te répondre... Si un jour je me penche un peu plus sur php et Cie, je regarderai cela de plus près. C'était une piste pour les gens plus avertis...
On peut se contenter de compléter la doc d'installation de Limesurvey en précisant la valeur à apporter à la variable $rooturl, c'est-à-dire l'adresse url "en dur" si le serveur ne renvoie pas la valeur de _SERVER.

Samuel REMOUE
DRTIC DRAAF Grand Est

Please Log in to join the conversation.

More
5 years 11 months ago #57276 by DenisChenu

rems wrote: Je ne suis pas assez compétent en la matière pour te répondre... Si un jour je me penche un peu plus sur php et Cie, je regarderai cela de plus près. C'était une piste pour les gens plus avertis...
On peut se contenter de compléter la doc d'installation de Limesurvey en précisant la valeur à apporter à la variable $rooturl, c'est-à-dire l'adresse url "en dur" si le serveur ne renvoie pas la valeur de _SERVER.

Oui,

C'est ce que l'on conseil en général, et c'est pour cela que rooturl est dans config.php en plus d'être dans config-default.php ;)

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form