Check out the LimeSurvey source code on GitHub!

liens caduques dans les pages de sauvegarde et chargement d'un questionnaire

More
6 years 5 days ago - 6 years 5 days ago #56967 by rems
Bonjour,

Les liens dans les pages de sauvegarde ou chargement d'un questionnaire sont caduques (que ce soit via les boutons du type "Sauver maintenant" ou via un groupe de mots "Retourner au questionnaire") : ils renvoient vers une page du type index.php/?sid=78719 ; l'adresse du site n'est pas reprise.

J'ai fait des tests sur des hébergements en ligne et un hébergement en local : idem.

Pour moi il s'agir d'une erreur dans l'application mais je n'ai pas rien trouvé à ce sujet sur le site des bugs.

Comment remédier à cela ?

Samuel REMOUE
DRTIC DRAAF Grand Est
Last Edit: 6 years 5 days ago by rems.

Please Log in to join the conversation.

More
6 years 5 days ago #56981 by Nickko
Comment remédier à l'absence de ce bug dans la liste des bugs ?
Je regarderais-ce soir si ça fonctionne chez moi.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 years 5 days ago - 6 years 5 days ago #56982 by rems

Nickko wrote: Comment remédier à l'absence de ce bug dans la liste des bugs ?

On peut dire çà comme çà !

Nickko wrote: Je regarderais-ce soir si ça fonctionne chez moi.

Merci.
Au cas où, voici le lien du questionnaire test en ligne : eticeal.educalor.com//index.php?sid=78719

Samuel REMOUE
DRTIC DRAAF Grand Est
Last Edit: 6 years 5 days ago by rems.

Please Log in to join the conversation.

More
6 years 5 days ago - 6 years 5 days ago #56992 by Nickko
Chez moi ça fonctionne, quelle version et quelle build de Limesurvey utilises-tu ?

Je vois que tu as un template très customisé, je pense que ça peut aussi venir de là.

Essaie avec le template de base pour voir.

Nickko
Ergonome / Usability expert
Last Edit: 6 years 5 days ago by Nickko.

Please Log in to join the conversation.

More
6 years 5 days ago #56996 by rems

Nickko wrote: Chez moi ça fonctionne, quelle version et quelle build de Limesurvey utilises-tu ?


J'utilise la version 1.90+ Build 9642 et les applications de mes sites ne me signalent pas de mises à jour disponibles. C'est bien la dernière version stable. Par contre en me rendant sur le site j'ai constaté la sortie d'une nouvelle version en 1.91 Je vais essayer de mettre à jour un site test pour voir.

Nickko wrote: Je vois que tu as un template très customisé, je pense que ça peut aussi venir de là. Essaie avec le template de base pour voir.

Non, j'utilise le template limespired avec simplement l'image centrale du bandeau d'entête changée et les images latérales supprimées.

Samuel REMOUE
DRTIC DRAAF Grand Est

Please Log in to join the conversation.

More
6 years 5 days ago #56997 by Nickko
Ma réponse est la même, test avec le template de base.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 years 5 days ago #56999 by rems
J'ai testé en changeant le template : même problème.

Samuel REMOUE
DRTIC DRAAF Grand Est

Please Log in to join the conversation.

More
6 years 4 days ago #57007 by Nickko
Peut-être un pb de variable ds le fichier de conf par exemple.
dans config.ini tu as quoi à la section // File Locations ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 years 4 days ago - 6 years 4 days ago #57015 by rems
Tu parles sans doute du fichier config.php
J'avoue être pour le moment sur cette piste de variable mal déclarée ou mal interprétée...
Alors, pour les deux sites, voici son contenu à la section concernée :
$rooturl            =   "http://{$_SERVER['HTTP_HOST']}/"
$rootdir            =   dirname(__FILE__)

Mais je n'ai pas trouvé dans les fichiers de Limesurvey où est-ce que ces variables sont appelées...

Samuel REMOUE
DRTIC DRAAF Grand Est
Last Edit: 6 years 4 days ago by rems.

Please Log in to join the conversation.

More
6 years 4 days ago #57016 by Nickko
Tu es trop fort, tu m'as compris et pourtant ce n'était pas gagné, désolé.

On a la même chose ds le fichier.

Je seche un peu...
Je viens d'avoir une idée. Et si $_SERVER ne renvoyait pas ce qu'il doit...

Un peu tiré par les cheveux p-ê.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

Moderators: Nickko
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form