probleme maj version 3.0.1 avec plugin CAS

More
4 months 2 weeks ago #162308 by charlie_po
charlie_po created the topic: probleme maj version 3.0.1 avec plugin CAS
Bonjour,

Je sais qu'il y a des bugs reportés concernant les problèmes de m.a.j de la dernière version 3.0.1 avec les différentes BDD (j'ai également ce problème avec mysql) mais ce qui me bloque en premier lieu l'installation, c'est le plugin AuthCAS.

j'ai tenté l'installation de la m.a.j (ancienne version 2.73.0)

- Avec ce plugin (copie du dossier de l'ancienne version dans la nouvelle ) : impossible de terminer la mise à jour (bdd et appli) et j'ai ce message d'erreur


Fatal error: Declaration of AuthCAS::__construct(PluginManager $manager, $id) must be compatible with LimeSurvey\PluginManager\iPlugin::__construct(LimeSurvey\PluginManager\PluginManager $manager, $id) in /var/www/html/limesurvey_test/plugins/AuthCAS/AuthCAS.php on line 0



- sans ce plugin : aucun problème d'installation et de mise à jour de la base de données.


existe-t-il un rapport avec le bug rapporté ou en est-ce un autre ? est-ce un bug à reporter ou un erreur de procédure de ma part ?

merci d'avance pour vos lumières !

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #162310 by LouisGac
LouisGac replied the topic: probleme maj version 3.0.1 avec plugin CAS
l'arborescence et les espaces de noms des plugins a été changé dans la V3, les plugins doivent donc être mis à jour par leur auteur avant de pouvoir fonctionner.
The following user(s) said Thank You: charlie_po

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #162324 by charlie_po
charlie_po replied the topic: probleme maj version 3.0.1 avec plugin CAS
Je viens de contacter les auteur de ce plugin et il n'est pas prévu pour l'instant de le mettre à jour.

Je suis complètement bloqué quand à l'évolution de votre application puisque nous ne pouvons nous passer de cette extension. Sans cela nous sommes obligé de rester en version 2.73.0-171219.

Nous allons tenter de nous pencher sur l'évolution du plugin de notre côté mais pour cela nous aurions besoin de plus d'information quant à votre nouvelle architecture sur la partie plugin.

Auriez-vous une documentation à nous fournir ou pourriez-vous nous dire ce qui a changé, pourquoi et comment ?

Merci d'avance pour votre réponse

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #162326 by LouisGac
LouisGac replied the topic: probleme maj version 3.0.1 avec plugin CAS
Ne vous inquiétez pas, vous êtes loin d'être seuls dans ce cas là.

Pour l'instant nous travaillons sur l'application elle-même, il nous reste quelques fonctionnalités à déboguer.
Quand cela sera fait, nous proposerons la LS3 dans le comfortUpdate, et nous donnerons des indications aux développeurs pour qu'ils puissent mettre à jour leurs templates et leurs plugins.

Comme vous êtes français, si vous êtes vraiment pressé de passer à la nouvelle version et que seul ce plugin vous bloque, je vous conseille de contacter Denis Chenu. Il a activement participé au développement de la version 3 de LimeSurvey, et pourra vous aider avec le changement de namespace des plugins:
www.sondages.pro
The following user(s) said Thank You: DenisChenu, charlie_po

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #162335 by charlie_po
charlie_po replied the topic: probleme maj version 3.0.1 avec plugin CAS
merci pour votre réponse,

nous attendrons donc la finalisation de la version pour nous pencher sur le plugin et à terme, faire la mise à jour.

Cordialement

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #162373 by DenisChenu
DenisChenu replied the topic: probleme maj version 3.0.1 avec plugin CAS
Salut,

Pour info : j'avais mis en place AuthCAS chez un client. Par contre : poour l'instant aucun de mes plugins n'est compatible avec LimeSurvey 3.0 …
Donc, de mon coté : j'aurais tendance à
1. Attendre la stabilisation de la 3.0
2. Voir le problème de mise à jour de la 2.7X => vers la 3.0 : bugs.limesurvey.org/view.php?id=13086#c45359
3. Voir les problème des plugins : bugs.limesurvey.org/view.php?id=13090 + bugs.limesurvey.org/view.php?id=13091

Dans cet ordre

PS :

Il a activement participé au développement de la version 3 de LimeSurvey

Mouaif, c'est moins vrai depuis quelques mois et la fin de la validation HTML pour le RGAA

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 4 months 2 weeks ago by DenisChenu.

Please Log in or Create an account to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!