Problème si utilisation combinée de filtres conditionnels et de conditions

More
4 months 4 weeks ago #156938 by rems
rems created the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Bonjour,

Je viens de constater que lorsqu'on met un filtre conditionnel sur un groupe, toutes les autres conditions sur les questions du groupe sont ignorées. S'agit-il d'un bug ou est-ce un principe de conception ?

Je voudrais mettre un filtre conditionnel sur un groupe de questions tout en pouvant mettre des conditions de passage d'une question à l'autre au sein du groupe. A priori, au lieu de mettre un filtre conditionnel sur le groupe je dois ajouter la condition pour chaque question pour rendre opérantes les autres conditions des questions.

Samuel

Samuel REMOUE

Please Log in to join the conversation.

More
4 months 4 weeks ago #156946 by DenisChenu
DenisChenu replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Normalement cela fonctionne comme cela :

Les conditions des questions deviennent (condition du groupe) AND (condition de la question)

Par exmple
Groupe : A==1
Question : B==2

Tu auras comme condition finale
A==1 AND B==2

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 months 4 weeks ago #156955 by rems
rems replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Merci pour les explications, mais j'avais bien compris qu'en résultat final on avait un ET logique entre les deux, et c'est bien ce que je veux ;)
Le hic, c'est que dans mon questionnaire (LimeSurvey version 2.62.0+170124), les conditions que j'affecte aux questions du groupe sont sans effet si j'ai un filtre conditionnel sur le groupe. Si j'enlève ce dernier, elles fonctionnent bien.
Donc pour le moment, la condition globale que je voulais mettre sur le groupe, je suis obligé de la répliquer sur chaque question (et ça marche, heureusement). Je vais essayer de voir si le "phénomène" se reproduit sur un autre questionnaire... ou s'il s'agit d'un bug ;)

Samuel REMOUE

Please Log in to join the conversation.

More
4 months 4 weeks ago #156956 by DenisChenu
DenisChenu replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Comme cela : oui, c'est un bug.

Une question groupe par groupe ou tout en une page ?
En fait : j'ai bien rappelé le principe pour être sur : si il n'est pas respecté : ya un bug.

Tu as regardé le fichier de logique ? Pas d'erreur ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 months 4 weeks ago #156959 by DenisChenu
DenisChenu replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
A propos : si pas d'erreur, que tu es sur de ton coup mais que tu n'arrive pas à reproduire sur un questionaire plus simple : tu peux tout de même envoyer le questionnaire.
Par contre : les dev mettrons beaucoup plus de temps à corriger …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: LouisGac

Please Log in to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #156974 by rems
rems replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions

DenisChenu wrote: Une question groupe par groupe ou tout en une page ?

Les questions sont dans le même groupe et l'affichage est configuré à groupe par groupe.

DenisChenu wrote: Tu as regardé le fichier de logique ? Pas d'erreur ?

Pas d'erreur

DenisChenu wrote: si pas d'erreur, que tu es sur de ton coup mais que tu n'arrive pas à reproduire sur un questionnaire plus simple

En fait, pour le moment j'observe un comportement aléatoire... Je vais creuser pour voir ce qui fait que parfois c'est bien géré et parfois mal.

Samuel REMOUE
Last Edit: 4 months 3 weeks ago by rems.

Please Log in to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #157056 by rems
rems replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Le mode prévisualisation ne fonctionne pas pour le questionnaire entier : le navigateur rame... puis erreur : "La page n'est pas redirigée correctement". Seules les prévisualisations des groupes ou questions fonctionnent, les conditions sont biens respectées et les questions ne s'affichent bien que quand la condition est remplie (et disparaissent si on enlève la réponse).
En mode "Lancer le questionnaire avec cette invitation", en mode d'affichage "groupe par groupe", il y a des problèmes avec les conditions (d'une manière générale, seul le filtre condition du groupe est respecté). Si le mode d'affichage du questionnaire est question par question, par de soucis, je ne rencontre pas de problèmes avec le fonctionnement combiné des filtres conditionnels.
Je précise que j'utilise le modèle par défaut de Limesurvey, sans modification du modèle.

J'ai tout essayé :
  • utiliser le filtre conditionnel pour le groupe et les équations des filtres conditionnels pour les questions
  • utiliser le filtre conditionnel pour le groupe et "Fixer les conditions[/i"] pour les questions
  • utiliser deux conditions (and) dans les équations des filtres conditionnels pour les questions (avec une identique à toutes les questions).

En attendant de trouver l'origine du problème, je vais me résoudre à afficher le questionnaire question par question.
Ci-joint le fichier export de mon questionnaire ainsi que le fichier de logique.

Samuel REMOUE
Attachments:
Last Edit: 4 months 3 weeks ago by rems.

Please Log in to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #157226 by DenisChenu
DenisChenu replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Désolé, comme je part en vacances la semaine prochaine : j'ai du finir des trucs … ça passe avant …

Bon, pis là à tester rapidos : le questionnaire est compliqué : c'est pas dit qu'il n'y ai pas un boguie dans limesurvey sous certaines conditions.

Si je trouve le temps ce week-end : ca serait sympa que tu m'envoi une ligne de token aussi (les premières questions semblent préremplies …)

A propos : le tout en une page : c'est un manque de mémoire , c'est tout (un sacré paquets de calcul à faire): tu a&s tenté sur ton compte LimeSurvey Professional (previously LimeService) ? Il me semble qu'ils ont un paquet de mémoire dispo.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 4 months 2 weeks ago by DenisChenu.

Please Log in to join the conversation.

More
3 months 3 weeks ago #157765 by rems
rems replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions

DenisChenu wrote: A propos : le tout en une page : c'est un manque de mémoire , c'est tout (un sacré paquets de calcul à faire): tu a&s tenté sur ton compte LimeSurvey Professional (previously LimeService) ? Il me semble qu'ils ont un paquet de mémoire dispo.


J'ai pas mal travaillé avec le questionnaire et je pense qu'il s'agit effectivement d'un problème de "capacité" du serveur sur lequel est hébergé Limesurvey. J'ai un fonctionnement quelque peu aléatoire et la solution a consisté à afficher le questionnaire question par question en ayant pris soin au préalable d'enlever les filtres conditionnels des groupes puis les reporter sur les questions. J'ai pu constaté cela sur un autre hébergement, moins performant, dès lors que j'augmentais le nombre de questions/sous-questions. L'utilisation d'un système NAS perso assez performant m'a permis de tester un questionnaire plus "copieux" mais j'ai quand même atteint les limites ! Il faut que je revois le questionnaire dans sa composition pour l'alléger !

DenisChenu wrote: le questionnaire est compliqué

Oui, je l'ai voulu assez générique pour n'avoir que très peu de questions à mettre à jour chaque année. Je vais encore l'améliorer dès que je peux et pourrai le mettre à dispo. Y a t'il un endroit où on peut partager des questionnaires ?

Samuel REMOUE

Please Log in to join the conversation.

More
3 months 3 weeks ago #157767 by DenisChenu
DenisChenu replied the topic: Problème si utilisation combinée de filtres conditionnels et de conditions
Sinon, hésite pas à tester sur ton compte limeserce , c'est gratuit pôur 25 réponses par mois.

Il y avait avant un endroit pour déposer des questionnaires, ils n'existe plus … peut être remonter le bogue

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!