Dernière version 2.06lts recommandée ?

More
3 months 1 week ago #156814 by gantier
gantier created the topic: Dernière version 2.06lts recommandée ?
Bonjour,

Dans la branche 2.06lts (sur github ), il semble que 2 failles XSS aient été corrigées en mars mais la release note ne les mentionnent pas.

Est-il "safe" d'utiliser la version en l'état ?

Merci d'avance.
Cordialement.

PS : chère équipe limesurvey, j'ai bien prévu de migrer vers la dernière version mais certains éléments hors de mon contrôle m'en empêchent pour l'instant... :)

Please Log in to join the conversation.

More
3 months 1 week ago #156816 by LouisGac
LouisGac replied the topic: Dernière version 2.06lts recommandée ?
oui.

Please Log in to join the conversation.

More
3 months 1 week ago #156817 by LouisGac
LouisGac replied the topic: Dernière version 2.06lts recommandée ?
par ailleurs la version de Denis Chenu dispose d'autres améliorations que les simples maj de sécurité:
github.com/SondagesPro/LimeSurvey-SondagesPro

Please Log in to join the conversation.

More
3 months 1 week ago #156819 by Ben_V
Ben_V replied the topic: Dernière version 2.06lts recommandée ?

LouisGac wrote: par ailleurs la version de Denis Chenu dispose d'autres améliorations que les simples maj de sécurité:
github.com/SondagesPro/LimeSurvey-SondagesPro


Salut Louis,

une de ces amélioration est de supporter php7, mais je ne suis pas sûr que celà ne soit pas également le cas pour la branche 2.6 LTS; Les releases notes mentionnent une correction de bug (#12093) concernant l'édition des modèles de courriels, mais rien de plus.

Peux-tu nous donner quelques éléments d'information à ce sujet?

Merci.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 months 1 week ago #156820 by LouisGac
LouisGac replied the topic: Dernière version 2.06lts recommandée ?
la branche de LimeSurvey devrait également intégrer les correctifs pour la version 7 de PHP.... après tout, mettre à jours sa version de PHP est également une question de sécurité.

Donc: si vous rencontrez des bugs sur la LTS avec PHP7: n'hésitez pas à les rapporter.
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

More
3 months 1 week ago #156821 by Ben_V
Ben_V replied the topic: Dernière version 2.06lts recommandée ?
ok merci... effectivement le plus simple c'est encore d'essayer et de rapporter les bugs... même si je ne pense pas que ça coince à beaucoup d'endroits !

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 months 1 week ago #156823 by DenisChenu
DenisChenu replied the topic: Dernière version 2.06lts recommandée ?
Il me semble que j'ai ramené les correctifs PHP7 sur la lts. Et si je corrige une faille sécu sur la mienne j'apporte sur la lts.
Il ne doit y avoir que la meilleure génération des messages de courriel, l'export xlsx et les attributs par extensions au final '(d'important).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now