problème avec les video flash

More
4 months 2 weeks ago #155328 by Al_M
Al_M created the topic: problème avec les video flash
Bonjour
Je fais des tests d'insertion de video Flash dans une question. Le dépot du fichier se passe correctement, et l'insertion dans la question à priori aussi. Par contre quand je demande un aperçu de la question ou quand j'active le questionnaire, je ne vois pas la video, j'ai un carré blanc. Au clic droit sur ce carré, j'ai bien l'info "a propos d'Adobe Flash Player 25.0".
Je suis en version 2.63 mais le problème est identique sur une version 2.06
Pour écarter tout problème lié à l'environnement du serveur ou de mon poste de travail , j'ai également fait des tests sur mon installation sur le site limesurvey.org et depuis plusieurs ordinateurs windows ou linux , mais c'est la même chose. Dernière précision je suis connectée en super administrateur, donc filtre XSS désactivé.

Par contre l'insertion/ lecture de video mp4 ou de lien you tube sur la version 2.63 fonctionne correctement
Le manuel utilisateur ne mentionne pas de difficulté particulière et je n'ai rien trouvé sur le forum

Quelqu'un a t-il déjà rencontré ce problème ? Y a t-il une installation particulière à faire sur le serveur ?
Je me demande donc si cette fonctionnalité a un jour réellement marché.
Merci

Please Log in to join the conversation.

More
4 months 2 weeks ago #155330 by Nickko
Nickko replied the topic: problème avec les video flash
Tu l'héberges chez quel prestataire ta vidéo si ce n'est pas youtube ? Vimeo, Dalimotion ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 months 2 weeks ago #155331 by Nickko
Nickko replied the topic: problème avec les video flash
Tu l'héberges chez quel prestataire ta vidéo si ce n'est pas youtube ? Vimeo, Dalimotion ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 months 2 weeks ago #155332 by Al_M
Al_M replied the topic: problème avec les video flash
Nous avons une plateforme d'hébergement limesurvey en interne

Please Log in to join the conversation.

More
4 months 2 weeks ago #155333 by Nickko
Nickko replied the topic: problème avec les video flash
Oui mais pour le streaming... rien à voir avec Limesurvey. Ton player en Flash doit prendre la vidéo quelque part, sur un serveur qui la stream, comme Youtube.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 months 2 weeks ago #155336 by Al_M
Al_M replied the topic: problème avec les video flash
je dépose la vidéo sur le serveur : dans ma question icône flash, explorer le serveur, puis envoyer. Elle est apparemment copiée sous un répertoire flash. Je fais la même chose avec une video mp4, sauf qu'elle copiée dans un répertoire file et je n'ai aucun problème pour la lire dans mon questionnaire. Pourquoi ça fonctionne en mp4 et pas en flash ?

Please Log in to join the conversation.

More
4 months 2 weeks ago #155338 by Nickko
Nickko replied the topic: problème avec les video flash
Parce que Flash n'est pas à proprement parler un format de vidéo. à la limite le FLV (Flash vidéo en est un mais ce n'est pas du flash pour autant).

De plus, ton fichier MPEG-4 est sans doute inséré dans la page de formulaire générée à l'aide d'une balise <video> qui permet d'ajouter une vidéo comme on le fait avec une image, là, heureusement point de Flash.

Et comme les images que l'on met dans les pages web, on ne peut pas choisir n'importe quel format. le MPEG-4 est l'un des choix possible, hélas, contrairement aux formats d'images pour lesquels il y a un consensus, (tous les navigateurs acceptent PNG, JPEG et GIF) il n'en est pas de même avec les vidéos, il n'existe pas, à ma connaissance, un format qui correspond à tous les navigateurs, il faut alors prévoir plusieurs versions et les ajouter comme alternative.

Bref, passer par un service d'hébergement de vidéo comme Youtube (ou un autre) est de loin, à l'heure actuelle la plus simple manière de procéder quand on ne maitrise pas ce domaine.

Ce qui est mon cas et qui semble être le tien. Maintenant, si tu veux apprendre, cherche des infos sur la balise <video> tu devrais être sur la bonne voie.

Qui plus est, je ne sais pas ce qui se passe vraiment avec les manipulations que tu décris, ce que je te dis là, n'est l'hypothétique.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 months 2 weeks ago #155340 by Al_M
Al_M replied the topic: problème avec les video flash
c'est bien une video avec une extension flv que j'ai déposée. Ce qui est curieux c'est que d'après la doc utilisateur, c'est très simple à faire.
merci pour les réponses et la piste à creuser

Please Log in to join the conversation.

More
4 months 2 weeks ago #155341 by Nickko
Nickko replied the topic: problème avec les video flash
Tu as regardé la doc en français ou en anglais ? En anglais elle est parfois plus à jour.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 months 2 weeks ago #155442 by DenisChenu
DenisChenu replied the topic: problème avec les video flash
Avec le flash : il faut un lecteur : jplayer.org/ par exemple. tpartner du forum à peut être indiqué un workaroubnd quelque part ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 months 1 week ago #155688 by Al_M
Al_M replied the topic: problème avec les video flash
Après multiples essais, il s'avère que c'est l'extension de fichier swf qui est attendue pour l'ajout de vidéo via l'icône Flash.

L' extension flv devait fonctionner dans des versions antérieures de Limesurvey. Ma doc utilisateur était celle de la version 1.92. D'ailleurs dans la popup de propriétés du flash, il y avait un bouton nommé "pour FLV", qui n'existe plus maintenant.

En tout cas merci pour les réponses

Please Log in to join the conversation.

More
4 months 1 week ago - 4 months 1 week ago #155709 by LouisGac
LouisGac replied the topic: problème avec les video flash
rappelons que désormais, par défaut, la plupart des navigateurs désactivent flash (trop de problèmes de sécurité). Sur certaines versions de Chrome, cela se traduit par le fait que le texte "Installer Flash Player" s'affiche. Quand on clique dessus, Chrome propose d'activer Flash et recharge la page.

La balise HTML5 vidéo est aujourd'hui supportée par tous les navigateurs:
caniuse.com/#feat=video

Si vous avez besoin de supporter Internet Explorer < 11 :
videojs.com/
Last Edit: 4 months 1 week ago by LouisGac.

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now