Enquête sur iPad : connexion perdue

More
6 months 2 weeks ago #149783 by olivierBUDroit
olivierBUDroit created the topic: Enquête sur iPad : connexion perdue
Bonjour,

nous avons publié une enquête qui fonctionne parfaitement sur PC et sur mobile Android, en revanche impossible de valider sous ios, avec un message d'erreur "connexion perdue" .
Existe-t-il un paramètre particulier pour éviter cela ?

Par avance merci pour votre aide !

Please Log in to join the conversation.

More
6 months 2 weeks ago #149784 by Nickko
Nickko replied the topic: Enquête sur iPad : connexion perdue
À priori, il n'y a pas de raison pour cela. Tu utilises quelle version de Limesurvey ?
Lorsque tu dis sur iOS, tu as testé avec quel navigateur ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 months 2 weeks ago #149787 by olivierBUDroit
olivierBUDroit replied the topic: Enquête sur iPad : connexion perdue
Bonjour,

c'est un version installée sur le serveur de notre institution : Version 2.63.1+170305
J'ai testé avec Safari, Chrome, Firefox.
s'il n'y a pas de raison c'est que ça vient de chez nous alors, peut être à cause d URL rewriting.
Merci

Please Log in to join the conversation.

More
6 months 2 weeks ago #149790 by Nickko
Nickko replied the topic: Enquête sur iPad : connexion perdue
J'avoue que ce n'est pas le test que je fais souvent, là je n'ai pas d'URL pour tester ça avec un iOS. Mais à l'occasion je ferais le test de mon côté aussi.

L'erreur intervient à quelle moment, dès le premier écran ou tout à la fin du formulaire si tu as plusieurs pages de questions ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
6 months 2 weeks ago #149791 by olivierBUDroit
olivierBUDroit replied the topic: Enquête sur iPad : connexion perdue
La page d'accueil s'affiche normalement, ainsi que la première page de questions, mais dès la validation par "suivant" : connexion perdue.
On a testé d'autres questionnaires Limesurvey qui fonctionnent sur nos ipads, donc s'il n'y a pas de paramétrages particuliers au niveau des questionnaires qu'on aurait oublié, c'est sûrement un problème indépendant de Limesurvey...
Désolé pour le dérangement et merci encore !

Please Log in to join the conversation.

More
6 months 2 weeks ago #149796 by Ben_V
Ben_V replied the topic: Enquête sur iPad : connexion perdue
...pas d'Iframe au milieu de tout ça ?

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
6 months 1 week ago #149807 by olivierBUDroit
olivierBUDroit replied the topic: Enquête sur iPad : connexion perdue
Bonjour,
non pas d'iframe, juste une redirection de port, nos soupçons s'orientent vers cela.

Please Log in to join the conversation.

More
6 months 1 week ago #149808 by Ben_V
Ben_V replied the topic: Enquête sur iPad : connexion perdue
ok.. bizarre tout de même que ce bug n'affecte ni d'autres enquêtes, ni d'autres navigateurs....

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
6 months 1 week ago #149823 by olivierBUDroit
olivierBUDroit replied the topic: Enquête sur iPad : connexion perdue
Bon voila on a résolu le problème, notre S.I. a boosté la VM ( x2 en mémoire et x2 en CPU ) et modifié la conf du serveur memcached ( x2 mémoire ) et ajusté la conf. de php-opcache, optimisé une partie du timeout coté serveur apache 2.4.6.
Et ça marche :)
Rien à voir avec Lime survey donc... Désolé pour le dérangement et merci pour votre aide !
The following user(s) said Thank You: DenisChenu, Ben_V

Please Log in to join the conversation.

More
6 months 1 week ago #149824 by Ben_V
Ben_V replied the topic: Enquête sur iPad : connexion perdue
Merci du retour.. Ça peut tjrs servir à qqu'un on ne sait jamais ;)

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
6 months 1 week ago #149976 by DenisChenu
DenisChenu replied the topic: Enquête sur iPad : connexion perdue

olivierBUDroit wrote: Bon voila on a résolu le problème, notre S.I. a boosté la VM ( x2 en mémoire et x2 en CPU ) et modifié la conf du serveur memcached ( x2 mémoire ) et ajusté la conf. de php-opcache, optimisé une partie du timeout coté serveur apache 2.4.6.
Et ça marche :)
Rien à voir avec Lime survey donc... Désolé pour le dérangement et merci pour votre aide !

Boudiou,

Je sais que ios n'est pas exempt de bug, mais pourquoi ca passe sur android et workstation, mais pas sur ios ...

Tu avais quelquechose dans le log qui vous a mis sur la piste ?

Une partie du $_POST perdu en route ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now