Problème avec la configuration SMTP

More
1 year 5 months ago #135719 by michou
michou created the topic: Problème avec la configuration SMTP
Bonjour,

J'ai un problème pour faire fonctionner la partie envoi de mail.
J'utilise la version 2.50+ Build 160504
J'ai un serveur smtp sur une seconde machine sans authentification (exchange 2010)

J'ai tenté de configurer la partie message électronique avec l'adresse de mon serveur:25 et supprimer le mot de passe par défaut.
J'ai essayé en SSL ou sans cryptage et j'ai toujours le même message d'erreur.

L'envoi du courriel à ******* (*******@*******.fr) a échoué. Message d'erreur : Échec de la connexion SMTP. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting <li>Information de débogage SMTP :</li><pre>2016-05-06 14:03:50 SMTP ERROR: Failed to connect to server: (0) 2016-05-06 14:03:50 Échec de la connexion SMTP. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting </pre>
Tous les courriels n'ont pas été envoyés :

Je comprend vraiment rien au fonctionnement de limesurvey sur le sujet.
J'utilise cette configuration sur de multiples application sans souci pourtant.

Merci de votre aide

Please Log in to join the conversation.

More
1 year 5 months ago #135720 by Nickko
Nickko replied the topic: Problème avec la configuration SMTP
As-tu regardé dans les logs de ton serveur exchange si tu voyais qqch en rapport avec Limesurvey ?

As-tu essayé d'utiliser la méthode php. Par défaut ?

Nickko

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
5 months 4 weeks ago - 5 months 4 weeks ago #153029 by hpantoine12
hpantoine12 replied the topic: Problème avec la configuration SMTP
Bonjour,

Il semble que ce sujet n'a pas eu de suite pour une solution.

Je me retrouve dans ce même cas de figure.

J'ai installé Limesurvey en local sur wamp dans le dossier www

J'ai mis comme paramètres de courrier électronique les éléments suivants :

Mon courriel : ****@gmail.com

Administrateur

Méthode pour les courriels : SMTP

Hôte SMTP : smtp.gmail.com:587

Nom d'utilisateur SMTP : ****@gmail.com

mot de passe : ****

Cryptage SMTP : TLS

Mode debug pour SMTP : Toujours


Le message d'erreur et le suivant:

L'envoi du courriel à ***** (****@****.com) a échoué. Message d'erreur : Échec de la connexion SMTP.

github.com/PHPMailer/PHPMailer/wiki/Troubleshooting <li>Information de débogage SMTP :</li>

<pre>2017-04-21 14:22:44 SMTP ERROR: Failed to connect to server: (0) 2017-04-21 14:22:44 Échec de la connexion

SMTP. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting </pre>

Tous les courriels n'ont pas été envoyés :


Je ne comprends ce que cela veut dire au niveau de l'erreur. Je pense que je m'y prends mal.

J'ai cherché sur les forums, la doc et essayé des solutions mais rien ne fonctionne.

C'est pourquoi j'ai décidé de demander de l'aide sur le forum Limesurvey directement.

Je ne sais pas quoi faire d'autre.

Pouvez-vous m'aider s'il vous plaît ?

Merci bien
Last Edit: 5 months 4 weeks ago by hpantoine12.

Please Log in to join the conversation.

More
5 months 4 weeks ago #153031 by Ben_V
Ben_V replied the topic: Problème avec la configuration SMTP

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
5 months 4 weeks ago - 5 months 4 weeks ago #153034 by hpantoine12
hpantoine12 replied the topic: Problème avec la configuration SMTP
D'après ce que j'ai pu comprendre du lien que Ben_V m'a proposé il y a un réglage à faire depuis google gmail. Mais il n'a pas dit ce qu'il a touché dans les réglages.

Ce que j'ai fait comme changement c'est uniquement activé le IMAP.

Est-ce que je dois aussi réglé le paramètre de rejet ?


J'ai pourtant l'impression que mes paramètres de courriel son bon.

Merci
Last Edit: 5 months 4 weeks ago by hpantoine12.

Please Log in to join the conversation.

More
5 months 4 weeks ago - 5 months 4 weeks ago #153036 by hpantoine12
hpantoine12 replied the topic: Problème avec la configuration SMTP
J'ai modifié mes paramètres maintenant j'ai l'erreur suivante :

Envoi des rappels...

L'envoi du courriel à ****** (******@gmail.com) a échoué. Message d'erreur : Échec de la connexion SMTP. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting <li>Information de débogage SMTP :</li><pre>2017-04-21 16:28:40 SERVER -> CLIENT: 220 smtp.gmail.com ESMTP y11sm12170323wrd.23 - gsmtp 2017-04-21 16:28:40 CLIENT -> SERVER: EHLO 127.0.0.1 2017-04-21 16:28:40 SERVER -> CLIENT: 250-smtp.gmail.com at your service, [78.193.109.34] 250-SIZE 35882577 250-8BITMIME 250-STARTTLS 250-ENHANCEDSTATUSCODES 250-PIPELINING 250-CHUNKING 250 SMTPUTF8 2017-04-21 16:28:40 CLIENT -> SERVER: STARTTLS 2017-04-21 16:28:40 SERVER -> CLIENT: 220 2.0.0 Ready to start TLS 2017-04-21 16:28:40 CLIENT -> SERVER: EHLO 127.0.0.1 2017-04-21 16:28:40 SERVER -> CLIENT: 250-smtp.gmail.com at your service, [78.193.109.34] 250-SIZE 35882577 250-8BITMIME 250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH 250-ENHANCEDSTATUSCODES 250-PIPELINING 250-CHUNKING 250 SMTPUTF8 2017-04-21 16:28:40 CLIENT -> SERVER: AUTH LOGIN 2017-04-21 16:28:40 SERVER -> CLIENT: 334 VXNlcm5hbWU6 2017-04-21 16:28:40 CLIENT -> SERVER: cHJvamV0dGVzdG1haWxAZ21haWwuY29t 2017-04-21 16:28:40 SERVER -> CLIENT: 334 UGFzc3dvcmQ6 2017-04-21 16:28:40 CLIENT -> SERVER: 2017-04-21 16:28:40 SERVER -> CLIENT: 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 support.google.com/mail/?p=BadCredentials y11sm12170323wrd.23 - gsmtp 2017-04-21 16:28:40 SMTP ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 support.google.com/mail/?p=BadCredentials y11sm12170323wrd.23 - gsmtp 2017-04-21 16:28:40 Erreur SMTP : échec de l'authentification. 2017-04-21 16:28:40 CLIENT -> SERVER: QUIT 2017-04-21 16:28:40 SERVER -> CLIENT: 221 2.0.0 closing connection y11sm12170323wrd.23 - gsmtp 2017-04-21 16:28:40 Échec de la connexion SMTP. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting </pre>
Tous les courriels n'ont pas été envoyés :


c'est une installation en local WAMP


Mes paramètres de courriel :

Mon courriel : ****@gmail.com
Administrateur
Méthode pour les courriels : SMTP
Hôte SMTP : smtp.gmail.com:587
Nom d'utilisateur SMTP : ****@gmail.com
mot de passe : ****
Cryptage SMTP : TLS



Paramètres de rejet :

Type de serveur : IMAP
Nom du serveur et port : imap.gmail.com:993
Type de chiffrement : SSL


Peut-on m'aider à résoudre ce problème ?
Merci bien
Last Edit: 5 months 4 weeks ago by hpantoine12.

Please Log in to join the conversation.

More
5 months 4 weeks ago #153042 by hpantoine12
hpantoine12 replied the topic: Problème avec la configuration SMTP
Quelqu'un a une solution ? c'est urgent. Je ne vois pas ce que je peux modifier d'autre.

Please Log in to join the conversation.

More
5 months 3 weeks ago #153172 by Nickko
Nickko replied the topic: Problème avec la configuration SMTP
Tu as lu le message :
Username and Password not accepted. Learn more at 535 5.7.8 support.google.com/mail/?p=BadCredentials y11sm12170323wrd.23

et

Password command failed: 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 support.google.com/mail/?p=BadCredentials

As-tu été voir à l'adresse indiquée ?

Est-ce que tu as essayé de faire ce qui était indiqué ?
Quels résultats as-tu obtenu ?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now