Problemen met vraagtype file-upload (You don't have a valid session !)

More
4 years 10 months ago - 4 years 10 months ago #83782 by coeneisma
coeneisma created the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Goedemorgen. Ik gebruik sinds kort Limesurvey voor feedback van klanten en voor onderzoeken. Alles werkt prima, alleen heb ik een probleem met het vraagtype bestandsupload. Ik krijg dan het volgende te zien:



Ik heb het ook al op andere servers (oa de demo-server) geprobeerd, en daar werkt de file-upload prima. In de IRC-chat heb ik de vraag ook gesteld en kreeg ik het volgende antwoord:

[21:48] <Coen_Eisma> I have Limesurvey installed. Everything works great, except for the file upload. When I hit the button 'Upload file' I get the message "You don't have a valid session !". Anybody got an idea how I can solve this ?
[21:58] <Mazi> Coen_Eisma, which Limesurvey version did you install?
[21:59] <Coen_Eisma> Hi Mazi. 1.92+ Build 120711
[21:59] <Mazi> you can try to export your survey and import it at our demo to see if you can reproduce the problem (which is most probably server setting related): demo.limesurvey.org/admin
[21:59] <Mazi> username: admin
[21:59] <Mazi> PW: test
[21:59] <Coen_Eisma> Great! I'll give that a try!
[22:03] <Coen_Eisma> It works on the demo-site, so - as you predicted - it must be a server setting issue
[22:08] <Coen_Eisma> any idea what it could be?
[22:16] <Mazi> Coen_Eisma, there are some session issues listed here: docs.limesurvey.org/Installation+FAQ&str...tions+for+LimeSurvey
[22:16] <Mazi> problem might depend on file size, depending on the server configuration.
[22:16] <Mazi> the Limesurvey forums should also contain some topics about it, use the search feature or google
[22:17] <Mazi> ...and check for the suhosin module on your server.


Nu ben ik niet zo techi en heb ik geen flauw idee wat suhosin module is.

Iemand hier een idee hoe ik dit op kan lossen?
Attachments:
Last Edit: 4 years 10 months ago by coeneisma.

Please Log in to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #83794 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Wat is u hosting ?
Met twee server en één loadbalancer ik heb de samen probleem maar niet specifiek voor upolad.


Sorry voor mijn Nederlands, ik ben een fransman wonend in Belgie ik leer Nederlands sinds kort. ik begrijp een beetje maar ik spreek niet heel goed.

Nickko
Ergonome / Usability expert
Last Edit: 4 years 10 months ago by Nickko.

Please Log in to join the conversation.

More
4 years 9 months ago #83925 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Dag Nickko, dank voor je antwoord.

De installatie draait bij HOSTMDS. We hebben daar als reseller meerdere domeinen draaien. Op een ander domein op dezelfde server draait ook een limesurvey-installatie en daar werkt de file-upload wel gewoon.

Ik heb inmiddels ook een nieuwe limesurvey-installatie op hetzelfde domein geïnstalleerd en daar werkt de file-upload ook niet. Het moet dus iets met de server- of MySQL-instellingen te maken hebben. Iemand een idee?

Please Log in to join the conversation.

More
4 years 9 months ago #83928 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Test u met de samen file elke keer ?
En de MySQL, de samen elke keer ?

Ik denk dat de file grootte kan kan een probleem zijn.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 9 months ago #83984 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Opgelost! Vraag me niet waarom het werkt, maar het werkt. Ik heb bij de desbetreffende vraag de maximale bestandsupload vergroot naar 2048 (ipv de 1024 die stond ingesteld), en nu werkt alles zoals het hoort. :)

Nickko, dank voor je input. Ik kan weer verder.

Please Log in to join the conversation.

More
4 years 9 months ago #84016 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)

coeneisma wrote: Opgelost! Vraag me niet waarom het werkt, maar het werkt. Ik heb bij de desbetreffende vraag de maximale bestandsupload vergroot naar 2048 (ipv de 1024 die stond ingesteld), en nu werkt alles zoals het hoort. :)

Nickko, dank voor je input. Ik kan weer verder.


Helaas, te vroeg blij... Het werkt toch niet. Ik blijf de 'Invalid session' melding krijgen. Heb de hele server en LimeSurvey al opnieuw geïnstalleerd, maar dit werkt ook niet.. :(

Iemand nog een idee? We hosten bij HostMDS .

Please Log in to join the conversation.

More
4 years 9 months ago #84017 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Ik heb en klein idee, proberen met : $sessionhandler = 'db'; in config.php
Standaard is file maar soms problemen kunnen zich voordoen als de instabiliteit en het DB kan oplossen.

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 9 months ago #84020 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Dag Nickko,

Heb de regel toegevoegd aan config.php maar helaas geen resultaat.

Please Log in to join the conversation.

More
4 years 9 months ago #84022 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Welke versie en welke bluild gebruik je?

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 9 months ago #84025 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Versie 1.92+ Build 120725

Please Log in to join the conversation.

More
4 years 9 months ago #84030 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Geen bekende fout voor deze versie...

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 9 months ago #84055 by Nickko
Nickko replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)

Nickko
Ergonome / Usability expert

Please Log in to join the conversation.

More
4 years 9 months ago #84239 by coeneisma
coeneisma replied the topic: Problemen met vraagtype file-upload (You don't have a valid session !)
Uiteindelijk opgelost! Nickko heeft me fantastisch geholpen (dank daarvoor), maar we kregen het niet voor elkaar.

Zojuist geupdatet naar versie 1.92+ Build 120801 en daar zat een patch in die dit probleem heeft aangepakt. Zowel upload als preview werkt nu zoals het hoort.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now