Charts not drawing with Bitnami ruby module

More
4 years 1 week ago #111355 by hiramegl
hiramegl created the topic: Charts not drawing with Bitnami ruby module
Hi, I'm using a Bitnami ruby stack to run Lime Survey. I've installed the module and seems to work perfectly fine, except that the graphs are never drawn. I installed the package from 2014-07-30, created a survey and a question group with 3 questions. I activated the survey and then submitted the survey a couple of times. When I generate a report no graphs are shown with the statistics, even though I check the "show graphs" checkbox. Is there any option I need to change in the configuration? Or anything I need to install? I don't get any graph for HTML, PDF or XLS.

Thanks for your help beforehand and for your great software!

Best regards.

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111357 by DenisChenu
DenisChenu replied the topic: Charts not drawing with Bitnami ruby module
Hi,

Did you have gd or gd2 activated ? Look at your config.php.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111361 by hiramegl
hiramegl replied the topic: Charts not drawing with Bitnami ruby module
Hi Denis, thanks for your quick reply!

I tried to open config.php but get an error message "page does not exist".
The admin home link which works fine is is:
"localhost/limesurvey/index.php/admin/survey/sa/index"

And i've tried:
"localhost/limesurvey/config.php"
"localhost/limesurvey/config/config.php"
"localhost/limesurvey/application/config/config.php" <- forbidden

I logged in as the admin user.

Any other idea how to check gd or gd2 activated?

Thanks again!

Hiram

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111362 by DenisChenu
DenisChenu replied the topic: Charts not drawing with Bitnami ruby module
Oups ... not config.php but phpinfo ... on general settings manual.limesurvey.org/Global_settings#Overview_.26_Update

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: hiramegl

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111363 by hiramegl
hiramegl replied the topic: Charts not drawing with Bitnami ruby module
It seems that is configured with "gd", as far as i understood:

'./configure' '--prefix=/bitnami/rubystack-linux-x64/output/php' '--enable-fpm' '--with-fpm-user=daemon' '--with-fpm-group=daemon' '--with-apxs2=/bitnami/rubystack-linux-x64/output/apache2/bin/apxs' '--with-iconv=/bitnami/rubystack-linux-x64/output/common' '--with-libxml-dir=/bitnami/rubystack-linux-x64/output/common' '--with-expat-dir=/bitnami/rubystack-linux-x64/output/common' '--with-zlib-dir=/bitnami/rubystack-linux-x64/output/common' '--enable-mbstring=all' '--enable-soap' '--enable-bcmath' '--enable-ftp' '--with-xmlrpc' '--enable-fastcgi' '--enable-force-cgi-redirect' '--enable-cgi' '--with-imap=/bitnami/rubystack-linux-x64/src/imap-2007f' '--with-imap-ssl=/bitnami/rubystack-linux-x64/output/common' '--with-dom=/bitnami/rubystack-linux-x64/output/common' '--with-png-dir=/bitnami/rubystack-linux-x64/output/common' '--with-gd' '--with-zlib' '--with-curl=/bitnami/rubystack-linux-x64/output/common' '--with-jpeg-dir=/bitnami/rubystack-linux-x64/output/common' '--enable-exif' '--with-openssl=/bitnami/rubystack-linux-x64/output/common' '--with-LDAP=/bitnami/rubystack-linux-x64/output/common' '--with-freetype-dir=/bitnami/rubystack-linux-x64/output/common' '--enable-calendar' '--enable-ctype' '--enable-pcntl' '--enable-session' '--with-regex=php' '--enable-spl' '--enable-zip' '--with-bz2=/bitnami/rubystack-linux-x64/output/common' '--enable-sockets' '--with-gmp=/bitnami/rubystack-linux-x64/output/common' '--with-xsl=/bitnami/rubystack-linux-x64/output/common' '--with-mcrypt=/bitnami/rubystack-linux-x64/output/common' '--with-icu-dir=/bitnami/rubystack-linux-x64/output/common' '--with-tidy=/bitnami/rubystack-linux-x64/output/common' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-pdo_sqlite=/bitnami/rubystack-linux-x64/output/sqlite' '--with-sqlite3=/bitnami/rubystack-linux-x64/output/sqlite' '--with-gettext' '--enable-intl' '--with-readline=/bitnami/rubystack-linux-x64/output/common'

Thanks Denis!

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111384 by DenisChenu
DenisChenu replied the topic: Charts not drawing with Bitnami ruby module
Yes, but maybe not activated: you have the gd version somewhere.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: hiramegl

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111390 by hiramegl
hiramegl replied the topic: Charts not drawing with Bitnami ruby module
You mean to find it somewhere in the path?
Or is it a .so file?

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111391 by DenisChenu
DenisChenu replied the topic: Charts not drawing with Bitnami ruby module
In the phpinfo:



Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Attachments:
The following user(s) said Thank You: hiramegl

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111392 by hiramegl
hiramegl replied the topic: Charts not drawing with Bitnami ruby module
Seems to be ok:

gd

GD Support enabled
GD Version bundled (2.1.0 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.4.8
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 8
PNG Support enabled
libPNG Version 1.5.9
WBMP Support enabled
XBM Support enabled

Directive Local Value Master Value
gd.jpeg_ignore_warning 0 0

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago #111406 by DenisChenu
DenisChenu replied the topic: Charts not drawing with Bitnami ruby module
Then try to activate debug mode , maybe some other error.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!