Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: The answer appear in the form of signs

The answer appear in the form of signs 2 years 3 months ago #106908

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9264
  • Thank you received: 1320
  • Karma: 383
Big issue here : DB is created with latin1_swedish_ci

With 1.92 and 2.00: it's OK : utf8_unicode_ci

When you report the bug, please put the link here. Before it's fixed : you can take the last 2.00 version.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
Last Edit: 2 years 3 months ago by DenisChenu.
The administrator has disabled public write access.

The answer appear in the form of signs 2 years 3 months ago #106910

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9264
  • Thank you received: 1320
  • Karma: 383
Seems there are some lack of default collation in your DB.

Please try (if you use mysql)
ALTER DATABASE yourdatabasename DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci;

And try : deactivate/reactivate
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

The answer appear in the form of signs 2 years 3 months ago #106911

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9264
  • Thank you received: 1320
  • Karma: 383
Hi,
If you don't know : just put your hoster name.

But we need to know 2 more things :
- Your DB server
- What is the version installed at start (because seems there are some fix when utdating)

Did you remind the process ? What version did you install ?

PS: here you can fix if you have access to your DB

ALTER DATABASE yourdbname DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci;
ALTER TABLE yourdbname.lime_survey_XXXX COLLATE utf8_unicode_ci
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
Last Edit: 2 years 3 months ago by DenisChenu.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.961 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form