Check out the LimeSurvey source code on GitHub!

Problem with "Create MaxDiff question type" on Safari 5.1 (iphone 4)

More
4 years 11 months ago #73174 by Renier
Hi Guys

In the manual there is an article that describe how to use Javascript to do Most/Least type questions.

See article < docs.limesurvey.org/Workarounds%3A+Quest...axDiff_question_type >

a Working example of this question is also available on < www.partnersinc.biz/surveys//index.php?s...91&newtest=Y&lang=en >

On IE and Firefox the question behaves correctly.
When selecting Most for the same question, IE and Firefox brings up the invalid message and then unselect the incorrectoption again.

On Safari 5.1 (Iphone), this does however not happen.
The message box is presented BUT the incorrect answer is left as is and the page can be submitted.

A Second problem is also that when you click on an answer again (one that is already shown) the message is incorrectly shown. Further detection can then also be switched off.


Does any one have an idea how to fix this?


Will appreciate your help!!

Regards
Renier

Please Log in to join the conversation.

More
4 years 11 months ago #73179 by holch
You are honestly "molesting" someone with a maxdiff survey on an Iphone?

;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 11 months ago #73182 by Renier
Just using it to test with Safari!
:lol:

Please Log in to join the conversation.

More
4 years 11 months ago #73208 by Mazi
Hmm... since this is more a HTML/JS/CSS question and nothing really Limesurvey related, you might get better support at a web developer forum.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #77535 by Mazi

Renier wrote: On Safari 5.1 (Iphone), this does however not happen.
The message box is presented BUT the incorrect answer is left as is and the page can be submitted.

Could you meanwhile solve the problem? This might be template related, because the workaround often depend on a certain template structure.
There is a new Limesurvey Template Shop which offers two different iPhone optimized Limesurvey templates .


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form