Check out the LimeSurvey source code on GitHub!

"You have to login first" error right after successfully logging in - IE only

More
5 years 3 hours ago #72304 by lstrange
Hello - on my public-facing Limesurvey installation (Version 1.91 Build 10120), I recently encountered a problem where I log into Limesurvey as admin. It shows that I'm sucessfully logged in, with my name displaying. Once I click anything, it takes me back to the login screen and says "You have to login first."

I'm using IE 8. I can successfully log in with a few other browsers I've tried (Firefox, Chrome)

I recently got a new machine so I'm guessing it's some setting in Internet Explorer causing this, but just not sure which one. I have a few other users with the same problem, but one user is not having the problem.

I've got a test server version of Limesurvey running and can successfully log in there with no problem there using IE 8.

Any ideas? Thanks for any help.

Lainie

Please Log in to join the conversation.

More
5 years 2 hours ago - 5 years 2 hours ago #72305 by Ben_V
Lainie,
look at this other post , it sounds very similar !

Ben.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
All LS releases => bit.ly/1VMuTDu | 2.06lts => bit.ly/1Qv44A1
Demo surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 5 years 2 hours ago by Ben_V.

Please Log in to join the conversation.

More
4 years 11 months ago #72359 by Mazi
The linked thread above offers some solutions.

I'm not sure if this is a session related problem though because if it works with other browsers, that would mean it's browser related. Did you try clearing cahce and cookies?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 11 months ago #72364 by lstrange
I cleared temporary internet files and cookies - no change. I even changed my browsing history (check for new pages...) setting from "Automatically" to "Every time I visit the page".

I went ahead and tried what was mentioned in the linked post by placing an .htaccess in the /limesurvey folder, which included the following info.

<IfModule mod_php5.c>
php_value session.auto_start 0
</IfModule>

This had no effect also.

Please Log in to join the conversation.

More
4 years 11 months ago #72365 by Mazi
When you are using other browsers, can you log in AND use some functions at the admin backend without problems?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 11 months ago #72369 by lstrange
I just now added a new user with no problem using Firefox.

Please Log in to join the conversation.

More
4 years 11 months ago #72371 by Mazi
Then it's probably a browser related problem.

If the admin interface works fine with a different browser and filling out a survey with IE also works, then there is no real problem :-)


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #78244 by jhgorse
I can confirm that this auto-logout behavior also occurs with Google Chrome 18.0.1025.151 on Mac OS X 10.6.8.

It occurs on the default admin as well as created admin users.

When using Chrome's "Incognito" the behavior is no longer an issue.

Safari works.

Because "Incognito" worked, it is probably a cookie issue. I reloaded the page with the Developer Tools. Under Resources->Cookies->MyLimeSurveyServerIP there seemed to be redundant cookies. Delete them and the auto-logout no longer occurred.

Cheers,
Joe
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form