Check out the LimeSurvey source code on GitHub!

Array type question not saving any data!!

6 years 2 months ago #53064 by bluenatt
Hi, I´ve been using LimeSurvey for quite some time now, but never had this type of issues before.

It seems that the array type questions are not saving the answers. I have all those columns blank in my database.
This happens at random it seems, because for some of those questions the answers are saved.

Most of the time, when I have more than one array question type in the same group, it just saves the data from the first and leaves the rest blank.

I´ve tried setting all of these questions mandatory, but with the same result.

I don´t know what to do, I´ve lost 3 weeks of answered surveys because of this.

I´m using the latest build of version 1.90, the survey has about 760 questions, the database is on mysql.

I didn´t know if this was the correct forum to post this, I apologise if I posted it in the wrong place.


Please Log in to join the conversation.

6 years 2 months ago #53068 by holch
First of all: Wow! What are you guys doing. There are so many people with enormous questionnaires. I just can't believe anyone is willing to fill in a 760 question "monster".

Now let's try to get to the point and try to fix this. When you say the "rest is blank", how do you check that? Does it appear in the back end only, or also when you export the data? Maybe you can have a look at the MySQL-Database and see, if the data is saved there at least?

By the way: with some database engines 760 questions (which means a lot more columns of course) can be already too much (see documentation, e.g. MySQL InnoDB: Maximum number of 1000 columns).

But in your case the columns are there, just not filled, so the above limit seems not the problem.

Can you export a file with the results? You can delete all lines, but one, maybe? You could also file a bug report and make it private, so you can upload for example the exported survey and maybe a results file, and anything that can help to find the problem.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

6 years 2 months ago - 6 years 2 months ago #53069 by bluenatt
An Update on the issue.

I have the questions group by group. Let´s say that on the first group, I have 2 array type questions, among others...

When I answer that first group, all of the answers from all of the questions are saved OK in the database.
Then I answer the 2nd group and when I go to the 3rd group (meaning that the 2nd group its being saved on the database), I loose the answers on the 1st group, starting from the 2nd array question to the end of the group.

I really don´t know what to do, It´s so weird, never happened to me before...

I´ve tried moving the survey to another server, removing the token-based persistance, making the survey anonymous, But so far, nothing has solved the issue.
Last Edit: 6 years 2 months ago by bluenatt.

Please Log in to join the conversation.

6 years 2 months ago #53070 by bluenatt
Ok, I´ll do that and post it here.

Please Log in to join the conversation.

6 years 2 months ago #53072 by bluenatt
I´ve opened a bug report:
Uploaded the survey structure and a couple of responses exported.
I hope it helps to solve the issue.

Please Log in to join the conversation.

6 years 2 months ago #53174 by Mazi
Bug fixed. There will be a bugfix release this evening.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form