Check out the LimeSurvey source code on GitHub!

Session Timeout not working

6 years 3 months ago #52054 by sumitmalik

I've set the session timeout to 60 seconds (just for testing, I want it to be 3600). But the system is not timeouting me.

I've even uncommented the line:

@ini_set('session.gc_maxlifetime', $sessionlifetime);

But no help. I ever tried changing the session.gc_maxlifetime value in php.ini and restarted the server too, but its still not timeouting me.

Any help?

Please Log in to join the conversation.

6 years 3 months ago #52055 by Mazi
I don't think this is a Limesurvey issue. Even if you set a limit in Limesurvey, this limit might be ignored/get overwritten by global webserver settings.
The timeout usually works correctly, this is being confirmed by users complaining about running into timeouts.

If you still think it's a bug:
Please test if the problem still exists at the latest release . If so please open a ticket at the Bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the Bugtracker so we can follow the progress.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form