Check out the LimeSurvey source code on GitHub!

Can't add answer options for multiple choice

More
6 years 7 months ago #43595 by raz
I'm trying to add options to a multichoice question and when I enter a code for the option and the answer, nothing happens after I click save changes or add a new option....anyone help?

Please Log in to join the conversation.

More
6 years 7 months ago #43596 by holch
Hmmm, it is very difficult to help with so little information. It could be anything:

- you are doing something wrong...
- there is something wrong with the server
- there is something wrong with your LS installation
- etc.

So, it would be good to provide as much information as you can.

Is the survey active / inactive?

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 7 months ago #43597 by raz
www.thunderbaywebhosting.ca/atbsurvey/admin/admin.php

Check it out? I also imported a question and got 3 multiple choice options but for some reason I cannot edit the options to what I want. When I click save changes it goes back to the default responses from the import.

Please Log in to join the conversation.

More
6 years 7 months ago #43598 by raz
try to add a multiple choice question

Please Log in to join the conversation.

More
6 years 7 months ago #43599 by holch
Well, in order to do that I would have to login. So this is not really working. ;-)

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 7 months ago #43603 by Mazi
0. Which Limesurvey version do you use?

1. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

2. Does the problem only occur when trying to add answers for a multiple choice question?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 7 months ago #43608 by raz
holch wrote:

Well, in order to do that I would have to login. So this is not really working. ;-)



admin
password


I believe it only happens when I try to add answer options to any type of question.

Please Log in to join the conversation.

More
6 years 7 months ago #43609 by holch
I have tested it, and really, it is not possible to add any item. I was able to add questions, but I couldn't add answer items.

By the way: because I thought it might be a problem with the admin password being still the default I changed it to "admin".

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 7 months ago #43610 by holch
It is really weird. You can create new questions, but you can't create answer options.

Did you try a reinstall already?

Are the permissions for the database set correctly?

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 7 months ago #43656 by Mazi
Please try to re-upload all files in binary mode.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 1 month ago #52752 by ningwang
I am having the same issue. I can create the question, either a dropdown or radio button, but I can't add any answer options. I clicked the "+", but nothing get added and when I click "Save", the option input box erased my input and changed to default text.

Please Log in to join the conversation.

More
6 years 1 month ago #52809 by Mazi
Please list all solutions listed in this thread you have tried to follow to solve the problem.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 1 month ago #52840 by ningwang
Ah, I tried to re-upload the package in binary. And problem solved =)

Please Log in to join the conversation.

More
6 years 1 month ago #52848 by Mazi
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form