Questions Embeded JavaScript

More
1 year 7 months ago #135373 by codelogic
codelogic created the topic: Questions Embeded JavaScript
The JavaScript I write in the “Questions” and “Help” text does not show up in the LimeSurvey Question Editor even when in source mode but it does show up in the database. I can do some html tags such as headers but I can’t have attributes like “id”.
Is anyone else seeing the behavior in there LimeSurvey? I feel like it happened with the update I did recently but I’m not 100% sure.
Any saves done from LimeSurvey on a question deletes the JavaScript I had wrote so I’ve been having to edit all questions directly from the database and that takes a lot more time.
Does anyone have a solution?

Please Log in to join the conversation.

More
1 year 7 months ago #135375 by holch
holch replied the topic: Questions Embeded JavaScript
There is another thread about this somewhere and there seems to be a bug report already.

Here the discussion: www.limesurvey.org/forum/design-issues/1...rce-code-not-visible

Short term solution: Switch off the editor or use it in the popup mode.

Here the bug report: bugs.limesurvey.org/view.php?id=11064

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
1 year 7 months ago #135376 by codelogic
codelogic replied the topic: Questions Embeded JavaScript
Thank you!
I didn't try hard enough to find the current post on this. Sorry about that. I didn't look under design but that makes sense now that I think about it.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!