Expression manager behaving strangely with multipe choice question

More
3 years 1 month ago #112850 by holch
holch created the topic: Expression manager behaving strangely with multipe choice question
This was driving me insane for the last 30min.

I tried to show the question text from my first question (Q1) in the text of the second question (Q2).

So what I did was the following:
{Q1.question}

Acccording to manual.limesurvey.org/Expression_Manager this should work.

But it didn't. It always told me that the variable was not defined. I changed the question names, I did all kinds of tweaking and then I tried to switch the question type of the first question from multipe choice to list (radio) and suddenly there was no problem anymore.

But actually, why should "Q1.question" not work for the multipe choice question? I can understand that it won't work with the results, because there can be various, but .question?

How would I access the question text otherwise?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #112856 by Ben_V
Ben_V replied the topic: Expression manager behaving strangely with multipe choice question
Holch,

I've tried with a (quiet old) 1.92+ Build 120919 LS version, and the same bug occurs....

If Q1 is a multiple choice question, we can't reuse neither {Q1} nor {Q1.something} further in the survey and this could be a problem for tailoring.

If you can report this bug, thanks for pasting the link to the ticket here...because I want to fix my 1.92 platform as well.

Ben.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 3 years 1 month ago by Ben_V.

Please Log in to join the conversation.

More
3 years 1 month ago #112860 by holch
holch replied the topic: Expression manager behaving strangely with multipe choice question
Hi Ben, I am actually not too sure if it is a bug. I think it is because the multiple choice question being so different than any other question, especially the way it is stored in the data base. So i think using {Q1} wouldn't make sense. What would be writen in there? But {Q1.question} should work at least because it makes sense even for multiple choise.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

More
3 years 1 month ago #112861 by holch
holch replied the topic: Expression manager behaving strangely with multipe choice question
But i will make a bug report, to see what the response is.

Just out of curiosity: why would you still have a 1.92installation?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 month ago #112865 by Ben_V
Ben_V replied the topic: Expression manager behaving strangely with multipe choice question
1) for multiple choice questions you can be right and maybe it's not a bug :unsure: I hope we will know about all of this very soon.

2) Some key points why I still use 1.92 installations:
- The main reason is that I've some very particular adaptations developed under 1.90 release, and everything is ok when exporting to a 1.92installation, but I experienced some issues with versions ≥2.00 (due to my adaptations).

- 1.92 fits my needs because I only need EM engine to perform assessments & calculations not really surveys… I have no need of the (great) central participant database and I've a lot of to learn before being able to manage or create plugins.
Note that a very easy improvement when using 1.92 version consist to try the use of a recent em_javascript.js file (pick it in the current stable release) to get freshly added EM new functions. For the moment, I'm lucky and haven't notice big incompatibility.

- I use to run 2 or 3 parallels installations (1 install = 1 subdomain) sharing the same db.
1.92 is still very light, around 3500 files and can work properly with only a very small part of those files for a dedicated front-end install.
A "live" example: For this installation , less than 400 files of the original 1.90 package and only 6,3 MB free space are required (NO admin and NO public statistics )
;)

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 years 1 month ago #112866 by holch
holch replied the topic: Expression manager behaving strangely with multipe choice question
Ahhh, understood. But I personally wouldn't want to miss the new features of the 2.05 version.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 month ago #112873 by DenisChenu
DenisChenu replied the topic: Expression manager behaving strangely with multipe choice question
Hi,

Did you tryb Q1_SQ001.question.

It's not really a bug, but it's unclear and need optimisation.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: Ben_V

Please Log in to join the conversation.

More
3 years 1 month ago #112876 by Ben_V
Ben_V replied the topic: Expression manager behaving strangely with multipe choice question
Hi Denis,

Tried! There is no problem with subquestions and all available EM suffixes can be used (.question, .SGQA, etc.). :)

Could be very useful to get the same thing for the main question.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 years 1 month ago #112879 by holch
holch replied the topic: Expression manager behaving strangely with multipe choice question
Yes, I know that the subquestions work. That is why I thought it was on purpose and not really a bug.

But I think it should work for the main question as well, especially the suffices that refer to the main question.

Because this is what people expect.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!