standard hide conditions do not work in version 2.05 ?

More
3 years 2 months ago - 3 years 2 months ago #112228 by Falk
Falk created the topic: standard hide conditions do not work in version 2.05 ?
Hello,

a hide condition is easy to set up but it does not seem to work.
In my case it does not work to switch on a question neither in dependance from a previous multiselect (checkbox) answer nore from a radio answer.
It always keeps hidden.

And here I also ask myself why in each of both cases there are completly different condition formulars:
a) at multi-select it is: ((Q0_SQ002.NAOK == "Y"))
b) at single-select / radio answers it is: ((Q1.NAOK == "A3"))

My questions now:
1.) Why are the relevance equations different? At b) I would have expected ((Q1_A3.NAOK == "Y")) !! But this is not possible to set/create.
2.) Why does it not work in both cases? The conditioned question does not appear!

I have the most actual version installed (v.2.05).
Many thanks to you for a quick answer / solution!!
Last Edit: 3 years 2 months ago by Falk.

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #112234 by Falk
Falk replied the topic: standard hide conditions do not work in version 2.05 ?
Addition...

The equations ((Q0_SQ002.NAOK == "Y")) and ((Q1.NAOK == "A3")) are shown in the general menu (after selecting the question selector).
BUT in the relevance equation field itself there is displayed instead of them:
To a): ((23761X93X1267SQ002.NAOK == "Y"))
To b): ((23761X93X1257.NAOK == "A3"))
And I cannot edit it anymore.

As this (number) is so complicated I ask myself how I could edit the relevance field manually anyway.
How does that work (as it seems that you should know a complicated number)?...
And why are there such numbers?

It is hard to understand the condition mechanism especially when the designer/wizzard for it does not work!...
Please help me to understand this. I may have a better chance to help myself then.

Thank you very much!

PS: Am I the only one who has problems with the condition mechanism ?
Last Edit: 3 years 2 months ago by Falk.

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #112239 by tpartner
tpartner replied the topic: standard hide conditions do not work in version 2.05 ?

And here I also ask myself why in each of both cases there are completly different condition formulars...

This is because multiple-choice questions use sub-questions which each have their own column in the database. These sub-questions are answered null or "Y". Single-choice questions have a single column in the database. The answers depend on your codes.


BUT in the relevance equation field itself there is displayed instead of them:...And I cannot edit it anymore.

If the conditions designer is used, relevance is automatically inserted using SGQA values instead of question codes. Once this is done you cannot edit the condition in the Relevance field - you must go back to the conditions designer to edit or remove the condition(s). More info here - manual.limesurvey.org/Setting_conditions...s_as_of_Version_1.92 .


.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 3 years 2 months ago by tpartner.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!