Template issue - Multiple choice with comments

More
3 years 4 months ago - 3 years 4 months ago #104477 by zn0610
zn0610 created the topic: Template issue - Multiple choice with comments
Dears

I met a template issue only occuered at qestion type(Multiple choice with comments)

The checked box and subqusetions are not at same line, I changed to other templates and same.

Please below with reference.



If I made some mistake when I changed template? But all tempalte are same.

Do you know how to fix it to same line?

Thanks
Attachments:
Last Edit: 3 years 4 months ago by zn0610.

Please Log in to join the conversation.

More
3 years 4 months ago - 3 years 4 months ago #104499 by tpartner
tpartner replied the topic: Template issue - Multiple choice with comments
It looks like you are using a copy of the basic template.

Add this to the end of template.css:
.multiple-opt-comments ul.subquestions-list {
    width: 100%;
}


.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 3 years 4 months ago by tpartner.

Please Log in to join the conversation.

More
3 years 4 months ago #104703 by zn0610
zn0610 replied the topic: Template issue - Multiple choice with comments
Hi Tpartner

Thanks for your helps.

It still doesn't work even I changed template to default.

Also I crewated a new local website for testing by Xampp.

It still have same issue...both IE and Google Chrome, I have no idea...

I view source and found there are too many space and enter as below pic.



Do you know why this happaned?

Thanks

Jerry
Attachments:

Please Log in to join the conversation.

More
3 years 4 months ago #104800 by tpartner
tpartner replied the topic: Template issue - Multiple choice with comments
Can you activate a test survey?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 4 months ago - 2 years 10 months ago #105116 by zn0610
zn0610 replied the topic: Template issue - Multiple choice with comments
Hi Tpartner

Sorry for my late responds.

Please find test link below:
[removed]

I change it to default tamplate.

Thanks

Jerry
Last Edit: 2 years 10 months ago by DenisChenu.

Please Log in to join the conversation.

More
3 years 4 months ago #105134 by tpartner
tpartner replied the topic: Template issue - Multiple choice with comments
Try this:

.multiple-opt-comments ul.subquestions-list {
	width: 100%;
}
 
.multiple-opt-comments ul.subquestions-list label.answertext {
    width: auto;
}


.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 4 months ago - 3 years 4 months ago #105146 by DenisChenu
DenisChenu replied the topic: Template issue - Multiple choice with comments
Hi Tony ,
What do you think of
.multiple-opt-comments .subquestions-list .option {
    width: 50%;
}

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 4 months ago by DenisChenu.

Please Log in to join the conversation.

More
3 years 4 months ago #105154 by tpartner
tpartner replied the topic: Template issue - Multiple choice with comments
That would push the first <span> element out to 50% of its parent (the <li>), but I think the <ul> needs to be pushed out to 100% before manipulating any of its children. The <ul> does not default to 100% because of "display:table;".


.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 4 months ago #105178 by DenisChenu
DenisChenu replied the topic: Template issue - Multiple choice with comments
A quick test with FireBug seems OK, but maybe more because ul are already large. (and with FF).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
2 years 10 months ago - 2 years 10 months ago #111133 by johnvc
johnvc replied the topic: Template issue - Multiple choice with comments
Hello
I am encountering this same problem above. "The checked box and subqusetions are not at same line".
I have tried the 3 solutions posted.
1) Add this to the end of template.css:
.multiple-opt-comments ul.subquestions-list {
width: 100%;
}

2) .multiple-opt-comments ul.subquestions-list {
width: 100%;
}

.multiple-opt-comments ul.subquestions-list label.answertext {
width: auto;
}
3) .multiple-opt-comments .subquestions-list .option {
width: 50%;
}

None are working.
Is there a solution for this?

Edit: More details, the 1st question displays correctly, the subsequent question displays incorrectly!



Thanks..
my link : [removed]
Attachments:
Last Edit: 2 years 10 months ago by DenisChenu.

Please Log in to join the conversation.

More
2 years 10 months ago #111147 by tpartner
tpartner replied the topic: Template issue - Multiple choice with comments
That survey is not accessible.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 years 10 months ago #111303 by johnvc
johnvc replied the topic: Template issue - Multiple choice with comments
Hello
quick update.
The option:
2) .multiple-opt-comments ul.subquestions-list {
width: 100%;
}

.multiple-opt-comments ul.subquestions-list label.answertext {
width: auto;
}
is in the template.css file.
Some how, overnight, everything works perfectly!
Don't know if it has something to do with cache clearing on the local PC, or the remote host.

Note to site admin, can you please remove the link I provided in my previous comment?
Thanks.
John

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now