Welcome, Guest
Username: Password: Remember me

TOPIC: Japanese language is not displaying correctly when png is generated

Japanese language is not displaying correctly when png is generated 2 years 3 months ago #100991

  • skye
  • skye's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I have a problem when I try to do responses and statistics in japanese then view the statistics using pdf/html. The PNG that was generated does not have correct japanese language. I can see squares instead of japanese. Please help.

Is this a bug?

Thanks.
Attachments:
The administrator has disabled public write access.

Japanese language is not displaying correctly when png is generated 2 years 3 months ago #100992

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 919
  • Thank you received: 131
  • Karma: 96
Assuming that you are using the latest 2.0 version:

For package size reasons the migmix-1p-regular.ttf font to show Japanese characters in the statistics graphs is not included with LimeSurvey.

Please download it from mix-mplus-ipa.sourceforge.jp/migmix/ ,
unzip and put the migmix-1p-regular.ttf file into the /fonts directory of your LimeSurvey installation.
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.
The following user(s) said Thank You: skye

Japanese language is not displaying correctly when png is generated 2 years 3 months ago #101000

  • DenisChenu
  • DenisChenu's Avatar
  • Online
  • Moderator Lime
  • Posts: 8234
  • Thank you received: 1122
  • Karma: 334
Yes,

And it's explain here :
github.com/LimeSurvey/LimeSurvey/blob/ma...-%20Japanese.ttf.txt

For information (mine), PDF use cid0jp font from tcpdf : did PDF are OK ?

And another think : to Carsten : i think we put an alert if there are font file in text but no fonts : maybe this a bug (little).

Denis
The administrator has disabled public write access.
The following user(s) said Thank You: skye

Japanese language is not displaying correctly when png is generated 2 years 3 months ago #101011

  • skye
  • skye's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
thank you for your answers. I tried it and it worked.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.133 seconds