Check out the LimeSurvey source code on GitHub!

next button disappearing

  • Lars_Akkermans
  • Lars_Akkermans's Avatar Topic Author
  • Visitor
  • Visitor
3 years 6 months ago #98826 by Lars_Akkermans
Hi all,

I have a problem preventing me from making a survey available to some contacts.

Description:
- survey created in offline version (v2.00 using xampp apache & mysql running) with multiple groups (22) and totalling 150 questions. Only minor internal references (getting a name to be printed in a question stuff). Offline version tested good.
- survey was imported in online version (v2.00) and problem occured: people no longer received a next button at the end of a question group.

Already tried:
- other (older) versions of survey: same problem
- survey oploaded question group by question group: as long as I only have five question groups, it works. Any other question group I add afterwards, it doesn't present the next buttons anymore.
- removing question groups: same finding as above (up to 5 ok, more than 5 question groups = it doesn't present the next buttons anymore)
- making bogus questionnaire on online verion: no problem

I any of you can give suggestions or help ... that would be much appreciated!
Lars

Please Log in to join the conversation.

More
3 years 6 months ago #98829 by DenisChenu
Hi,

Suspect a memory issue : did you have condition ? A lot of expression in your survey ?
Please try set debug at 2 in application/config.config.php

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

  • Lars_Akkermans
  • Lars_Akkermans's Avatar Topic Author
  • Visitor
  • Visitor
3 years 6 months ago #98833 by Lars_Akkermans
Thanks for your response!

For clarification: with memory issue, do you suspect a conflict or simple "lack off" memory?

Some conditions were included in the questions (but the same conditions were used before and after the crucial number of groups/questions).

I'll look into the debug setting and let you know.

Lars

Please Log in to join the conversation.

More
3 years 6 months ago #98844 by DenisChenu
Yes,:

Lack of memory for this survey with online server.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: Lars_Akkermans

Please Log in to join the conversation.

  • Lars_Akkermans
  • Lars_Akkermans's Avatar Topic Author
  • Visitor
  • Visitor
3 years 6 months ago #98863 by Lars_Akkermans
OK, it was a memory problem (not enough memory assigned to ...)

thank you very much!

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form