Check out the LimeSurvey source code on GitHub!

Relevance equation doesn't work if question code is a number

More
3 years 10 months ago #95160 by pweldon
Apologies if this is in the manual - I didn't spot it. Latest version of Limesurvey 2

[5.NAOK == "Y"] - this equation (written without the square brackets) doesn't work. But if the question code is changed to Q5:

[Q5.NAOK == "Y"] - then no problem.

Curiously, if you use the old method of setting conditions for a question, what you see in the relevance equation box is additional brackets - [((5.NAOK == "Y"))] and this works.

I have no problem with it - but it would be useful to add in to the manual - It took a lot of head scratching before I realised what the issue was!

Please Log in to join the conversation.

More
3 years 10 months ago #95164 by mdekker
I agree it is a hidden, but when you go to the QA page in LimeSurvey, you should see a warning about the invalid question code. I think the edit question screen should give a warning about question codes being duplicate or invalid. It is on the radar for future development. If you find a place where you think it should be in the manual, feel free to place it there yourself (it is a wiki).

---
Menno Dekker
The following user(s) said Thank You: pweldon

Please Log in to join the conversation.

More
3 years 10 months ago #95216 by pweldon
Thanks for that. I appreciate the confirmation. I wouldn't have liked to add anything to the wiki without being sure I was correct.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form