Inserting HTML5 source only works for super admins?

More
4 years 1 week ago #95090 by ubuntourist
ubuntourist created the topic: Inserting HTML5 source only works for super admins?
Hi,

I'm using Version 2.00+ Build 130406.

I have a user who would like to insert video clips into her survey. (And, considering where I work, I expect a LOT more requests for video in questions, answers, and elsewhere.) I did a quick test, creating a survey with HTML5 <video>, <source>, <track> tags, and all went well. However when she tried, it happily stripped out all of that.

Is this a user rights issue that can be solved without giving her the keys to the entire kingdom?

Please Log in to join the conversation.

More
4 years 6 days ago #95102 by tpartner
tpartner replied the topic: Inserting HTML5 source only works for super admins?
That may be a bug. In my opinion, the global "Filter HTML for XSS" setting should be, well, global.

Please file a bug report and post the link to the bug here so we can follow the progress.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 5 days ago #95127 by ubuntourist
ubuntourist replied the topic: Inserting HTML5 source only works for super admins?
To misquote the American automated phone system:

"Beep-beep-beep.
The link you provided, www.limesurvey.org/en/support/bug-tracker , yields a 404.
The new number is bugs.limesurvey.org/my_view_page.php
Please make a note of it."

Please Log in to join the conversation.

More
4 years 5 days ago #95128 by ubuntourist
ubuntourist replied the topic: Inserting HTML5 source only works for super admins?

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now