Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: No error message if validation fails

No error message if validation fails 2 years 10 months ago #93489

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Dear all,

thank you for being such a great community for this amazing tool!

If I submit a page with validations errors on it (in my current survey on 1.92+), the page is just reloaded and there is no message to the user that (s)he should check for errors, nor is the error focus()ed. I made quite a lot of surveys with LS and I could have sworn that there was a Javascript alert() when there was a validation error and that the question with the error was focused.

Did I somehow break the mechanism? I adapted some css and added a Javascript function to block the Enter and Backspace keys. But I tested it without the JS function too, and it shows the same behaviour. I also tried a jQuery $(document).ready(function{ $('.error').first().focus(); }); to at least focus the first question with a validation error when the page is reloaded, but that didn't work either.

I would greatly appreciate some advice on where to look for the error.

Thank you!

Best
Jonsen
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93502

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 8218
  • Thank you received: 1122
  • Karma: 333
Hello,

In general, there are validation error. Maybe some EM error or another think.

Can you put the lss file here or give us a link to test ?

Denis
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93518

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Hello Denis,

please find the link below. I put the test-token in the link.

Part of the message is hidden for the guests. Please log in or register to see it.

The first question is mandatory. I changed the class .good to have visibility: hidden.

Best
Jonsen
Last Edit: 2 years 10 months ago by jonsen. Reason: Added info
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93520

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5411
  • Thank you received: 1154
  • Karma: 479
It looks like your question.pstpl file might be missing some placeholders.

Test the survey with the default or citronade template and if those work, compare the question.pstpl files.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93526

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Hi tpartner, thank you for your reply. I tested both default and citronade, the validation alert doesn't show there either. So it seems to be a problem that's template-independent...
Last Edit: 2 years 10 months ago by jonsen. Reason: typo
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93546

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
For anyone who provides a solution to this, I will speak out an invitation to a fresh beer in a bar or club in Berlin... :)
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93549

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5411
  • Thank you received: 1154
  • Karma: 479
jonsen, can you attach the sample survey and an export of your template?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93554

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Yes, of course...

Attachments:
Part of the message is hidden for the guests. Please log in or register to see it.

Best
Jonsen
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93562

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
jonsen wrote:
For anyone who provides a solution to this, I will speak out an invitation to a fresh beer in a bar or club in Berlin... :)

I just now notice how cheap that sounds! Sorry... So now that includes a bed&breakfast :)

Anyways, the problem is that I don't know where to look for the error. I don't know at which place the code for this should be, so I can't trace it back to the php or anything...

Thanks alot for your help!

Best
Jonsen
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93563

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5411
  • Thank you received: 1154
  • Karma: 479
Hey, a beer is more than most folks offer us :laugh:

This is very odd - when I run the survey on my 1.92installation, with your template, everything works as expected. The pop-up alert appears and the "errormandatory" span is displayed - see below.

Dumb question, but have you updated to the final stable release of 1.92?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: jonsen

No error message if validation fails 2 years 10 months ago #93588

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
tpartner wrote:
Dumb question, but have you updated to the final stable release of 1.92?

Yes, I think so. It is v1.92+, build 120919...

The only thing (that I know of) that I changed in the php is the $showsgqacode option. Since another template doesn't fix it either and my template and survey work on your installation, I'm left baffled. Now the only thing I could try is to reinstall LS?!

Thank you for you effort!

Best
Jonsen
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93690

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5411
  • Thank you received: 1154
  • Karma: 479
Any luck Jonsen?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93725

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Hi Tony,

thanks for keeping track on this!

Indeed, the solution was found a couple minutes ago, after I scared up all people (technicians or not) involved in the project and was supported by them in looking for the error. After we made a fresh install of the same lime survey version and I stared to adapt the survey, I found the error. And I can't belive that I was that dumb! I totally forgot about the only thing next to $showsgqacode I changed in the php files:

I added $_GET = 99184; in the beginning of index.php to always forward visitors of the server root to the only survey, skipping the Welcome page. That worked out pretty nicely, and I didn't notice the faulty behaviour quite some time. Then, I couldn't connect it to that change...

So, it's resolved now! THANK YOU TONY for reproducing the non-error!

The only thing left is to find a new way to set the default survey. But I will make a new topic for this, as I can imagine that others might be interested in that, too.

All the best
Jonsen

P.S.: You can "cash in" beers and bed&breakfast any time :)
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93733

  • jonsen
  • jonsen's Avatar
  • Offline
  • Expert Lime
  • Posts: 83
  • Thank you received: 8
  • Karma: 1
Just one correction:
Of course it was $_GET[\'sid\'] = 99184;

The follow up topic ("Set a default survey, skip Survey List page") is here.
Last Edit: 2 years 10 months ago by jonsen.
The administrator has disabled public write access.

No error message if validation fails 2 years 10 months ago #93734

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4381
  • Thank you received: 618
  • Karma: 197
to skip the welcome page LS has an option in the interface now, as far as I recall. And the redirect I would make with .htaccess.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.235 seconds