Funny buttons

More
4 years 8 months ago #93362 by ricardo01
ricardo01 created the topic: Funny buttons
I've created a Max-diff questionnaire using this workaround
docs.limesurvey.org/tiki-index.php?page=...axDiff_question_type

However, the "next" and "previous" buttons don't look right. I've checked other surveys, and this happen only when I create the Max-Diff question




Does anybody know how to fix this? Thank you!
Attachments:

Please Log in to join the conversation.

More
4 years 8 months ago #93364 by KRav
KRav replied the topic: Funny buttons
This is only to solve if you post a url to your survey. It's a markup/css problem.


research on BLOGS - Professional LimeSurvey support
Consultant - Templates - Training - JQuery magic - Support - Coding - Survey creation and more..

Contact
Professional LimeSurvey support
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in to join the conversation.

More
4 years 8 months ago #93366 by ricardo01
ricardo01 replied the topic: Funny buttons
I don't understand...how does posting the URL solve the problem?

Please Log in to join the conversation.

More
4 years 8 months ago #93369 by holch
holch replied the topic: Funny buttons
Posting the URL will not fix the problem itself, but it can help someone to understand what happens.

You probably copied some CSS code or JS code from somewhere that includes the call to those buttons.

They are probably not even hosted on your server...

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 8 months ago #93453 by ricardo01
ricardo01 replied the topic: Funny buttons
I didn't copy any code from anywhere. The problem started after I upgraded limesurvey to Version 2.00+ Build 130305.

So I figured the problem could be related to a modified template I was using (based on limeinspired), that somehow gets corrupted or becomes incompatible when LS is updated.

So I used the limeinspired template available in Version 2.00+ Build 130305, to create a new version of my template and applied these changes:

www.limesurvey.org/en/forum/design-issue...stion-type-alignment

and my buttons are working now.


Attachments:

Please Log in to join the conversation.

More
4 years 8 months ago #93471 by tpartner
tpartner replied the topic: Funny buttons
Without seeing a live sample, I'm not sure how the workaround could have an affect (although it is quite old).

LS 2.0 uses <button> elements and jQuery UI styles instead of <input> elements for the navigation. Older templates need to have these styles added.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 8 months ago #93478 by ricardo01
ricardo01 replied the topic: Funny buttons
The workaround is not the problem. The problem was the old template. I used one of the templates in the most recent version of LS and it worked fine.

The morale: if you have customized templates, created with older versions of LS, update them.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!