Unable to preview / skips to the end

More
4 years 5 months ago #90760 by mvdct
mvdct created the topic: Unable to preview / skips to the end
Hi forum,

I wonder if you can help?

I've been playing around with limesurvey for a few months. I'm now giving my students limesurvey to play around with. In order to help them out I exported a few question groups for them to upload. 'Some' have managed to upload the question groups easily!

However, when I then get them to preview their new questionnaire things seem to come unstuck.
In two instances both students encounter the same issue. The welcome screen and the first uploaded question group previews but then the preview seems to jumps to the end of the questionnaire as if not other questions groups exist. Both students experience this same behaviour from limesurvey even though both have different questions groups on that first page.

I should be clear that question groups preview and behave well in my survey.

I have a feeling I'm missing something obvious, but I'm not sure what it is!
Any ideas?

With thanks in advance.

Please Log in to join the conversation.

More
4 years 5 months ago #90761 by helper
helper replied the topic: Unable to preview / skips to the end
What version and can you attach the offending survey here?

Please Log in to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #90771 by mvdct
mvdct replied the topic: Unable to preview / skips to the end
Hi,
Thanks for the reply.
In answer to your questions:
1. The latest version: Version 2.00+ Build 130103
2. Do you mean can I attach the *.lss? If so, now attached.
Thanks in advance
Attachments:
Last Edit: 4 years 5 months ago by mvdct.

Please Log in to join the conversation.

More
4 years 5 months ago #90832 by helper
helper replied the topic: Unable to preview / skips to the end
I am able to reproduce the issue and have submitted a bug report ( bugs.limesurvey.org/view.php?id=7161 ) that may be related.
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
4 years 5 months ago #90836 by mvdct
mvdct replied the topic: Unable to preview / skips to the end
Thanks for the help.

Interestingly, playing around with the order the question groups seem to have resolved the problem. It now previews.

Does that shed any more light on what was cuasing the problem in the first place?

With thanks

Please Log in to join the conversation.

More
4 years 5 months ago #91008 by helper
helper replied the topic: Unable to preview / skips to the end
I temporarily fixed my PHP error that I see when attempting to preview the questions and found that if you try to make this survey active you receive the following:
Activate survey(747174)
Error
Survey does not pass consistency check
 
The following problems have been found:
 
    Group gid-205 ("PSS"): This group does not contain any question(s).
    Group gid-206 ("GHQ"): This group does not contain any question(s).
 
The survey cannot be activated until these problems have been resolved.

I thought there was an issue with the first time that I downloaded your file, so I did another download with the same results. Both of the question groups in fact do not have any questions.
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
4 years 5 months ago #91012 by mvdct
mvdct replied the topic: Unable to preview / skips to the end
Thank you for your continued help on this topic.

You are right, the .lss did have two empty question groups at the end of the survey. They were empty because the student hadn't created those question groups yet.

i. Any idea why empty question groups right at the end of the survey would prevent viewing the rest of the survey? Why would limesurvey successfully show the welcome screen and then the first page of the questionnaire before then skipping to the end?

ii. Sadly, the other one of my students who was having a problem previewing her survey hadn't created any other question groups. The survey contains no empty question groups. So we may not have quite got to the bottom of this problem.

Again, thank you for your help.

Please Log in to join the conversation.

More
4 years 5 months ago #91014 by helper
helper replied the topic: Unable to preview / skips to the end
There could be a multiple ways of looking at what LimeSurvey intends for the preview. First, would be that no matter what error that there would be a preview; second, would be to attempt to display as much as possible without running into an error condition - of course, the second appears to be the case here. In addition, the survey logic checker does not check the syntax of potentially incomplete surveys.

Your second problem I believes stems from an error in the LimeSurvey code (see my bug report bugs.limesurvey.org/view.php?id=7161 ) - to make sure you may want have your second student turn on full debugging by changing their config:

Change the following:
// Use the following config variable to set modified optional settings copied from config-defaults.php
    'config'=>array(
    // debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
    // then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
    // on your webspace.
    // LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
        'debug'=>0,
        'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
    )

to the following:
// Use the following config variable to set modified optional settings copied from config-defaults.php
    'config'=>array(
    // debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
    // then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
    // on your webspace.
    // LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
        'debug'=>2,
        'debugsql'=>1 // Set this to 1 to enanble sql logging, only active when debug = 2
    )
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
4 years 5 months ago #91052 by mvdct
mvdct replied the topic: Unable to preview / skips to the end
again, thanks for the ongoing advice.

can i just check a dboule check a couple of things.

1. if we change the code in config-defaults.php it looks like we'll get more strict error message reporting, is that right?

2. i haven't edited a config-defaults.php in limesurvey before. i imagine i have the students users accounts locked down too tightly for them to edit this file. is it one file per user, or one per installation?

best

Please Log in to join the conversation.

More
4 years 5 months ago #91113 by helper
helper replied the topic: Unable to preview / skips to the end
The config.php (located in a sub-directory within each installation is at .../application/config/config.php). If your students can only modify the survey itself then this file will not be available for edit for them. Oh, and take note that this file is "config.php" and not "config-defaults.php" -- the second file is used at installation as a template for the creation of config.php.

The good thing about having this switch turned on to "2" is that you get real error reporting instead of something that may be sidestepped by the PHP runtime. And... I have seen no negative affects to have this switch on if your surveys are all in good shape.
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now