Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: Internet Explorer Issue

Internet Explorer Issue 3 years 4 months ago #90100

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90102

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Sorry for posting the pictures so many times. As you can see from the first one, the blue banner is off. The picture and text in the welcome page body appear fine with my computer's view, but I would imagine this issue will arise when participants are doing my survey.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90103

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
Okay, I see it now .

The problem is that when the browser window width is reduced, the big image full of logos (Partners?) is forcing its parent element to overflow the container element.

How about making that image responsive. That is to say that as the browser window is re-sized or the survey is viewed on a narrow screen, the image will automatically re-size itself to fit.

Add the following to the end of template.css. This will make the image 90% as wide as it's container up to a maximum of 1100 pixels. The height will automatically scale as the width changes.
.welcome-table {
	width: 100%;
}
 
.welcome-table img {
	width: 90% !important;
	height: auto !important;
	max-width: 1100px !important;
}

Now clear your browser cache, refresh the page and adjust the browser width. You will see the image magically change size :cheer:.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90104

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Hi,

I just added that to the end of my template.css, and nothing seemed to have happened. I cleared my browser history like you suggested. I will try it again in 10 minutes just to make sure.

But thanks for your help thus far :)
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90106

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
The survey doesn't seem to be active anymore.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90107

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Hi Sorry,

I just reactivated it. Maybe it will work now.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90108

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
You accidentally deleted the last closing bracket when you pasted the code.

This:
.boilerplate .answers {
	display: none;
 
.welcome-table {
	width: 100%;
}
 
.welcome-table img {
	width: 90% !important;
	height: auto !important;
	max-width: 1100px !important;	
}

Needs to be this:
.boilerplate .answers {
	display: none;
} 
 
.welcome-table {
	width: 100%;
}
 
.welcome-table img {
	width: 90% !important;
	height: auto !important;
	max-width: 1100px !important;	
}
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90109

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
Ah, now there's a problem caused by invalid HTML.

Change this:
.welcome-table img {

To this:
.welcome-table p img {
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90110

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Hi Tony,

Thanks for that. It worked, but now my logo which is inserted into the template is enormous. Should I just shrink it through the standard files?

I apologize for all the questions. I am learning how to use LimeSurvey everyday.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90111

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
See my answer 1 above.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90112

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Thanks Tony,

I really appreciate your help. I have one final javascript customization for confirmation messages which I have to figure out next. I have posted questions on this forum, but no one seems to know what to do.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90113

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5765
  • Thank you received: 1252
  • Karma: 512
Yeah, I sent a reply to your PM about that. There is no simply solution. Any JavaScript would be different for every page and depend on the question type(s) on the page.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Internet Explorer Issue 3 years 4 months ago #90115

  • NkemIku
  • NkemIku's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Karma: 0
Hi,
Thanks for your help. I just read your response in my PM. I will talk to my IT officer and see if you will know of more things to do.


HAve a good night.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.340 seconds