Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Template broken on index page

Template broken on index page 3 years 8 months ago #89291

  • creativologist
  • creativologist's Avatar
  • Offline
  • Junior Lime
  • Posts: 25
  • Thank you received: 1
  • Karma: 0
I have little issues getting the templates customized.

However, compare these two:

pianowizardacademy.com/survey/index.php/...x/sid/828785/lang/en

and this:

pianowizardacademy.com/survey/

On the latter, there is a missing header background. Don't really know why since the logo shows up fine, which are both referenced in the same manner in the template.

How do I go about fixing this?

thanks
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89298

  • jelo
  • jelo's Avatar
  • Offline
  • Platinum Lime
  • Posts: 1216
  • Thank you received: 150
  • Karma: 44
There is a second css which overrides your background with

body {
background-image: url("/survey/upload/templates/pianowizard/gradient2.gif");
}

This is not an external CSS but inline. Just remove the line and your background appears.
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89323

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
ANd maybe remove the
body.default line at line 202.

You can use FireBug to review css files
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89361

  • creativologist
  • creativologist's Avatar
  • Offline
  • Junior Lime
  • Posts: 25
  • Thank you received: 1
  • Karma: 0
Thank you for the quick responses.

The first solution fixed the problem. However, I now
find a problem on the page after registration. It is
missing the entire css

pianowizardacademy.com/survey/index.php/...ex/sid/75195/lang/en

This is a sample survey, so you can register with a fake address...then look at the next page. No reference of template.css

thanks
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89363

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6212
  • Thank you received: 1376
  • Karma: 539
That appears to be a bug. For some reason the {TEMPLATECSS} placeholder is not being parsed.

Please file a bug report and...
1. Give as much information as possible.
2. Provide step-by-step instructions how to reproduce the problem.
3. Provide screenshots and a sample survey.
4. Post the link to the bug here so we can follow the progress.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Template broken on index page 3 years 8 months ago #89366

  • creativologist
  • creativologist's Avatar
  • Offline
  • Junior Lime
  • Posts: 25
  • Thank you received: 1
  • Karma: 0
Did that

bugs.limesurvey.org/view.php?id=6992

thanks again

Vin
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89380

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
creativologist wrote: :blink: strange : TEMPLATEJS are OK, but not TEMPLATECSS. It's the same code :S
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Aw: Template broken on index page 3 years 8 months ago #89405

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6212
  • Thank you received: 1376
  • Karma: 539
strange : TEMPLATEJS are OK, but not TEMPLATECSS. It's the same code
Yeah, it's a problem with the way templatereplace() is called at the end of RegisterController.php.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.308 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form